Bug 1286920 - Can not register to Satellit-6.1.0-RHEL-7-20151130.0 by subscription-manager-gui
Can not register to Satellit-6.1.0-RHEL-7-20151130.0 by subscription-manager-gui
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Barnaby Court
Katello QA List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 00:56 EST by qianzhan
Modified: 2016-03-14 14:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 14:50:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
registration_blocked_in_GUI.png (147.36 KB, image/png)
2015-12-01 00:58 EST, qianzhan
no flags Details
rhsm.log (23.77 KB, text/plain)
2015-12-01 01:00 EST, qianzhan
no flags Details
can not register against satellite6.1 on rhel6.8 (239.99 KB, image/png)
2016-03-14 04:00 EDT, qianzhan
no flags Details
rhsm_on_rhel6.8.log (16.30 KB, text/plain)
2016-03-14 04:01 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2015-12-01 00:56:11 EST
Description of problem:
Can not register to satellit-6.1.0-RHEL-7-20151130.0 by subscription-manager-gui

Version-Release number of selected component (if applicable):
RHEL-7.2-20151030.0
Satellit-6.1.0-RHEL-7-20151130.0

How reproducible:
always

Steps to Reproduce:
1. Configure rhsm.conf on RHEL-7.2-20151030.0 against Satellit-6.1.0-RHEL-7-20151130.0.
 
2. Open subscription-manager-gui on RHEL-7.2-20151030.0, and click 'Register' button.


Actual results:
The registration process is blocked by an error: "AttributeError: 'EnvironmentScreen' object has no attribute 'set_environement'
". Please see attachment 'registration_blocked_in_GUI.png'

Expected results:
Registration should be successful.

Additional info:
Please see attachment 'rhsm.log'
Comment 1 qianzhan 2015-12-01 00:58 EST
Created attachment 1100721 [details]
registration_blocked_in_GUI.png
Comment 2 qianzhan 2015-12-01 01:00 EST
Created attachment 1100722 [details]
rhsm.log
Comment 3 Barnaby Court 2016-03-08 14:30:10 EST
I was unable to duplicate this issue using redhat-release-server-7.2-9.el7.x86_64 and sub-man gui with Satellite 6.2.
Comment 4 qianzhan 2016-03-14 03:58:59 EDT
This bug still can be reproduced with rhel6.8 and satellite6.1:

Version-Release number of selected component (if applicable):
1) RHEL-6.8-20160308.0:
subscription-manager: 1.16.8-3.el6
python-rhsm: 1.16.6-1.el6

2) Satellit-6.1.0-RHEL-7-20160209.1

Please see details from attachments: "can_not_register_against_satelliet_6.1_on_rhel6.8.png" and "rhsm_on_rhel6.8.log"

I believe this bug should be fixed, in case customers register RHEL6.8 against Satellite6.1. So I reopen it.
Comment 5 qianzhan 2016-03-14 04:00 EDT
Created attachment 1136094 [details]
can not register against satellite6.1 on rhel6.8
Comment 6 qianzhan 2016-03-14 04:01 EDT
Created attachment 1136095 [details]
rhsm_on_rhel6.8.log
Comment 7 Chris Snyder 2016-03-14 14:50:59 EDT
This has been fixed in upstream master (in subscription-manager). The fix should be in the next build of subscription-manager.

As this is not a bug in candlepin (but in subscription-manager), I am closing this bug.

For updates on the fix to this issue see https://bugzilla.redhat.com/show_bug.cgi?id=1313631

Note You need to log in before you can comment on or make changes to this bug.