Bug 1286949 - Camel Hawt.io console weird text selection after clicking on a Route in a Routes list
Camel Hawt.io console weird text selection after clicking on a Route in a Rou...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: stlewis@redhat.com
chunchen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 03:17 EST by Marek Schmidt
Modified: 2016-09-29 22:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Firefox 42, Fedora 22
Last Closed: 2016-09-07 17:10:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox text selection on camel route weirdness (85.37 KB, image/png)
2015-12-01 03:17 EST, Marek Schmidt
no flags Details
camel_build.log (22.82 KB, text/plain)
2016-01-15 04:24 EST, chunchen
no flags Details

  None (edit)
Description Marek Schmidt 2015-12-01 03:17:29 EST
Created attachment 1100761 [details]
firefox text selection on camel route weirdness

Description of problem:

The Camel Hawt.io Console route selection in the"Route" view in OSE3.1 does not behave properly on Firefox 

Version-Release number of selected component (if applicable):

oc v3.1.0.4-9-g72d3991
kubernetes v1.1.0-origin-1107-g4c8e6f4

How reproducible:
Always

Steps to Reproduce:
1. Deploy a Camel application on OSE 3.1 (e.g. https://github.com/fabric8io/ipaas-quickstarts/tree/redhat/quickstart/cdi/camel )
2. Open the OpenShift Console, select the pod, click on the 'Connect' button
3. Open the "Routes" folder in myCamel context
4. click on 'myCamel' cell in the route table  (only row in the table)
5. Move cursor up or down

Actual results:

the context will be selected, however a text selection is also started, which means all text is now shown with selection style (blue) and user must click on the row again to close the text selection.

Expected results:

clicking on the cell should select the context, no annoying text selection should occur

Additional info:

Works fine on Google Chrome.  Seems the problem is Firefox specific (tested on Fedora 22)
Comment 1 stlewis@redhat.com 2015-12-01 10:07:36 EST
Have gotten it to reproduce, also appears that the table of routes redraws regularly, so that could have something to do with the behavior, other pages such as the camel context list or list of queues in the ActiveMQ plugin don't appear to have this behavior.
Comment 2 stlewis@redhat.com 2015-12-01 11:50:16 EST
Think fixing up the redrawing helped here, commit is here, this will require a new release of openshift-jvm:

https://github.com/hawtio/hawtio-jmx/commit/af0a6c94a27c7d935a567cf04e561f14903dac67
Comment 3 stlewis@redhat.com 2016-01-12 09:35:07 EST
Fix mentioned above is in this PR -> https://github.com/openshift/origin/pull/6539
Comment 4 yapei 2016-01-12 21:01:58 EST
fix is not included in current latest puddle, will verify once merged in new OSE puddle
Comment 5 chunchen 2016-01-15 04:24 EST
Created attachment 1115062 [details]
camel_build.log
Comment 7 stlewis@redhat.com 2016-01-15 09:03:57 EST
Try following the steps under "Running the example with fabric8" in the readme, not sure what the state is for the s2i builds in the quickstarts.  More info available here as well -> http://fabric8.io/guide/quickstarts/running.html
Comment 8 chunchen 2016-01-18 01:16:35 EST
It's still reproduced with Firefox 43.0.4 against below OSE ENV:

[root@openshift-135 ~]# openshift version
openshift v3.1.1.4
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2


Tested on Fedora release 17 (Beefy Miracle)
Comment 9 stlewis@redhat.com 2016-01-18 10:30:33 EST
Ah, fix is probably only in origin, let me get it merged over to OSE, sorry about that.
Comment 10 stlewis@redhat.com 2016-01-18 10:51:03 EST
Hmm, nope, I see on the OSE branch it's at the expected version.  In the java console can you click on the top-right user menu and go into "Preferences", there should be an "About" page that lists loads of versions.  Can you verify that the java console version is 1.0.39?  If it isn't, *or* if you don't see an "About" entry in the preferences menu (should be the first item) it could be you just need to totally clear your browser cache.
Comment 11 chunchen 2016-01-18 21:39:19 EST
The java console version is 1.0.39, please refer to the below information:

About openshift-jvm
Version: 1.0.39
Commit ID: e79966878b9aba11b77fcb69db2cbbba12c662c9

Name                       Version
angular                     1.3.20
angular-patternfly          2.7.0
angular-resource            1.3.20
angular-route               1.3.20
angular-sanitize            1.3.20
bootstrap                   3.3.6
codemirror                  5.10.0
dagre                       0.7.4
es5-dom-shim                --  
graphlib                    1.0.7
hawtio-core                 2.0.25
hawtio-core-dts             2.0.22
hawtio-core-navigation      2.0.54
hawtio-extension-service    2.0.3
hawtio-forms                2.0.28
hawtio-integration          2.0.10
hawtio-jmx                  2.0.60
hawtio-preferences          2.0.5
hawtio-template-cache       2.0.5
hawtio-ui                   2.0.71
hawtio-utilities            2.0.26
jquery                      2.1.4
js-logger                   0.9.14
lodash                      3.2.0
patternfly                  2.7.0
toastr                      2.1.2
urijs                       1.17.0
zeroclipboard               2.2.0
Comment 12 chunchen 2016-01-18 22:25:56 EST
Tried this in origin with same version 1.0.39, it's also reproduced.
Comment 13 stlewis@redhat.com 2016-01-28 16:15:35 EST
K, figured it out, the table there had some other selection issues that I've sorted as well, I *think* the odd selection had to do with the table using a mousedown handler rather than a normal click handler.  Anyway, fingers crossed the fix is in this PR -> https://github.com/openshift/origin/pull/6888
Comment 14 chunchen 2016-01-31 21:56:36 EST
It's fixed in origin, checked with devenv_rhel7_3293, will check again when the PR is merged into OSE.
Comment 15 chunchen 2016-02-13 23:38:11 EST
Checked with the latest openshift version(v3.1.1.6-16-g5327e56) on OSE, the changes are still not merged into OSE.
Comment 16 chunchen 2016-02-17 02:24:51 EST
It's fixed against OSE, checked with the latest java console version(1.0.42).

[chunchen@F17-CCY daily]$ openshift version
openshift v3.1.1.902
kubernetes v1.2.0-origin
etcd 2.2.2+git


Could you please help to change it to ON_QA, then I can mark it as verified?
Comment 17 Marek Schmidt 2016-02-17 07:10:19 EST
I think we can just mark it as verified then...

Note You need to log in before you can comment on or make changes to this bug.