Bug 1286995 - PackStack should configure LVM filtering with LVM/iSCSI
PackStack should configure LVM filtering with LVM/iSCSI
Status: CLOSED ERRATA
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ivan Chavero
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 05:09 EST by Marko Myllynen
Modified: 2017-06-19 04:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 04:03:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2015-12-01 05:09:14 EST
Description of problem:
When using LVM/iSCSI as the Cinder backend the following issue can be hit:

[root@ctrl1201 ~(keystone_demo)]# systemctl status target
target.service - Restore LIO kernel target configuration
   Loaded: loaded (/usr/lib/systemd/system/target.service; enabled)
   Active: failed (Result: exit-code) since Mon 2015-11-30 13:44:02 EET; 35min ago
  Process: 6497 ExecStart=/usr/bin/targetctl restore (code=exited, status=1/FAILURE)
Main PID: 6497 (code=exited, status=1/FAILURE)
   CGroup: /system.slice/target.service
 
Nov 30 13:44:02 ctrl1201.example.com target[6497]: File "/usr/lib/python2.7/site-packages/rtslib/tcm.py", line 669, in __init__
Nov 30 13:44:02 ctrl1201.example.com target[6497]: self._configure(dev, wwn, readonly)
Nov 30 13:44:02 ctrl1201.example.com target[6497]: File "/usr/lib/python2.7/site-packages/rtslib/tcm.py", line 682, in _configure
Nov 30 13:44:02 ctrl1201.example.com target[6497]: + "device %s is already in use." % dev)
Nov 30 13:44:02 ctrl1201.example.com target[6497]: rtslib.utils.RTSLibError: Cannot configure StorageObject because device /dev/cinder-volumes/volume-8814e53b-c5d2-4349-a5b4-1d568180c187...ready in use.
Nov 30 13:44:02 ctrl1201.example.com systemd[1]: target.service: main process exited, code=exited, status=1/FAILURE
Nov 30 13:44:02 ctrl1201.example.com systemd[1]: Failed to start Restore LIO kernel target configuration.
Nov 30 13:44:02 ctrl1201.example.com systemd[1]: Unit target.service entered failed state.
Nov 30 14:19:17 ctrl1201.example.com systemd[1]: Stopped Restore LIO kernel target configuration.
Nov 30 14:19:18 ctrl1201.example.com systemd[1]: Stopped Restore LIO kernel target configuration.
Hint: Some lines were ellipsized, use -l to show in full.
[root@ctrl1201 ~(keystone_demo)]# 

The issue is explained in detail in:

https://access.redhat.com/solutions/1378733
https://bugzilla.redhat.com/show_bug.cgi?id=1139441

The verified solution was to configure LVM's global_filter in use.

Looks like PackStack should do this by default to prevent the issue.
Comment 4 Christopher Brown 2017-06-17 13:04:57 EDT
Pretty sure this is fixed if the reporter could confirm?
Comment 5 Marko Myllynen 2017-06-19 02:45:13 EDT
I don't have access to an environment to check now or in the near future, I think we can assume this is the case now as you suggest, it's been quite some time since the report. Thanks.

Note You need to log in before you can comment on or make changes to this bug.