Bug 128706 - crontab: You are not allowed to use this program
Summary: crontab: You are not allowed to use this program
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vixie-cron   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-28 13:10 UTC by Thomas Zehetbauer
Modified: 2008-05-09 17:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 23:13:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Zehetbauer 2004-07-28 13:10:14 UTC
package: vixie-cron-4.1-1

open("/etc/cron.allow", O_RDONLY)       = -1 ENOENT (No such file or
directory)
open("/etc/cron.deny", O_RDONLY)        = -1 ENOENT (No such file or
directory)
You (thomasz) are not allowed to use this program (crontab)
See crontab(1) for more information

       If the cron.allow file exists, then you must be listed therein
in order
       to  be  allowed  to  use this command.  If the cron.allow file
does not
       exist but the cron.deny file does exist, then you must not be
listed in
       the  cron.deny  file in order to use this command.  If neither
of these
       files exists, only the super user will be allowed to use this 
command.

Comment 1 Jason Vas Dias 2004-07-28 15:25:06 UTC
This is not a bug - as the manpage which you quoted states:
"
 If neither of these files exists, only the super user will
 be allowed to use this command.
"
That means that if neither /etc/cron.allow nor /etc/cron.deny exist,
only the superuser (root) can use crontab. 

Comment 2 Thomas Zehetbauer 2004-07-28 15:45:46 UTC
This is new and breaks things, vixie-cron should include and install
an empty /etc/cron.deny when updating.

Comment 3 John Dennis 2004-08-09 23:11:36 UTC
should be fixed as of mailman-2.1.5-10

we no longer use crontab, but rather install a mailman cron script in
/etc/cron.d, which is not supposed to have the same restriction. This
has some other advantages as well.

Comment 4 John Dennis 2004-08-09 23:13:07 UTC
sorry, I edited the wrong bugzilla apparently :-(


Note You need to log in before you can comment on or make changes to this bug.