Bug 128714 - (IT_45054) ifup does not set ETHTOOL_OPTS when nic is used in bonding
ifup does not set ETHTOOL_OPTS when nic is used in bonding
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 136794 (view as bug list)
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2004-07-28 11:26 EDT by Ian Amess
Modified: 2014-03-16 22:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 09:33:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Amess 2004-07-28 11:26:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When a nic device is configured to be part of a bonding device
ETHTOOL_OPTS is not set when the device is enslaved.

Version-Release number of selected component (if applicable):
initscripts-7.31.13.EL-1

How reproducible:
Always

Steps to Reproduce:
1.Configure nic to be a slave for a bonding device
DEVICE=eth2
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
ETHTOOL_OPTS="autoneg off speed 100 duplex full"
2.bring up bonding device ifup bond0
3.ethtool will show incorrect settings
    

Actual Results:  Device speed and duplex are not set correctly

Expected Results:  Device should show 100 Full Duplex settings

Additional info:

I added changed ifup script as follows 

Extract form ifup script

# slave device?
if [ "${SLAVE}" = yes -a "${ISALIAS}" = no -a "${MASTER}" != "" -a \
    -x /sbin/ifenslave ]; then
   RFLAG="" ; [ "${RECEIVEONLY}" = yes ] && RFLAG="-r"

   /sbin/ip link set dev ${DEVICE} down
   echo $"Enslaving ${DEVICE} to ${MASTER}"
   ifenslave ${RFLAG} "${MASTER}" "${DEVICE}"

#Added by ian.amess@o2.com to set device speed
#This could probably be done a better way but hey it works!!
   if [ -n "$ETHTOOL_OPTS" ] ; then
       /sbin/ethtool -s ${REALDEVICE} $ETHTOOL_OPTS
   fi

#End of fix...


   exit 0
fi

End of extract

This fixes the problem.
Comment 1 Bastien Nocera 2004-07-29 06:16:23 EDT
Adding to RHEL3 U4 Candidates.
Comment 3 Bill Nottingham 2004-10-23 00:18:32 EDT
*** Bug 136794 has been marked as a duplicate of this bug. ***
Comment 4 John Flanagan 2004-12-21 09:33:02 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-511.html

Note You need to log in before you can comment on or make changes to this bug.