Bug 1287166 - [abrt] vim-X11: vim_free(): gvim killed by SIGABRT
[abrt] vim-X11: vim_free(): gvim killed by SIGABRT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5455773ef0a21a41a07d67c661b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 11:21 EST by Joel Uckelman
Modified: 2016-04-29 05:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-29 05:30:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.44 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: core_backtrace (4.21 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: dso_list (7.63 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: environ (3.19 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: maps (42.00 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: mountinfo (3.15 KB, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: open_fds (332 bytes, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: proc_pid_status (1003 bytes, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details
File: var_log_messages (284 bytes, text/plain)
2015-12-01 11:21 EST, Joel Uckelman
no flags Details

  None (edit)
Description Joel Uckelman 2015-12-01 11:21:34 EST
Version-Release number of selected component:
vim-X11-7.4.827-1.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        gvim src/lib/df_parser.ypp
crash_function: vim_free
executable:     /usr/bin/gvim
global_pid:     2521
kernel:         4.2.5-201.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #11 vim_free at misc2.c:1707
 #12 ml_flush_line at memline.c:3545
 #13 ml_get_buf at memline.c:2519
 #14 ml_get at memline.c:2442
 #15 do_put at ops.c:3801
 #16 do_mouse at normal.c:2537
 #17 ins_mouse at edit.c:9257
 #18 edit at edit.c:1167
 #19 normal_cmd at normal.c:1343
 #20 main_loop at main.c:1351

Potential duplicate: bug 1256852
Comment 1 Joel Uckelman 2015-12-01 11:21:40 EST
Created attachment 1100954 [details]
File: backtrace
Comment 2 Joel Uckelman 2015-12-01 11:21:42 EST
Created attachment 1100955 [details]
File: cgroup
Comment 3 Joel Uckelman 2015-12-01 11:21:44 EST
Created attachment 1100956 [details]
File: core_backtrace
Comment 4 Joel Uckelman 2015-12-01 11:21:45 EST
Created attachment 1100957 [details]
File: dso_list
Comment 5 Joel Uckelman 2015-12-01 11:21:47 EST
Created attachment 1100958 [details]
File: environ
Comment 6 Joel Uckelman 2015-12-01 11:21:49 EST
Created attachment 1100959 [details]
File: limits
Comment 7 Joel Uckelman 2015-12-01 11:21:51 EST
Created attachment 1100960 [details]
File: maps
Comment 8 Joel Uckelman 2015-12-01 11:21:53 EST
Created attachment 1100961 [details]
File: mountinfo
Comment 9 Joel Uckelman 2015-12-01 11:21:54 EST
Created attachment 1100962 [details]
File: open_fds
Comment 10 Joel Uckelman 2015-12-01 11:21:56 EST
Created attachment 1100963 [details]
File: proc_pid_status
Comment 11 Joel Uckelman 2015-12-01 11:21:58 EST
Created attachment 1100964 [details]
File: var_log_messages
Comment 12 Karsten Hopp 2016-04-28 10:18:20 EDT
is this reproducable with the latest vim (vim-7.4.1718-1.fc22) ?  There have been many bugfixes that address segmentation faults like this one.

If you can't reproduce it anymore, can this report be closed ?
Comment 13 Joel Uckelman 2016-04-28 10:23:04 EDT
This was via the ABRT. No idea how I triggered it, so I couldn't reproduce it even with the version where it happened.
Comment 14 Karsten Hopp 2016-04-29 05:30:10 EDT
Ok, I'll close this report as I think this has been fixed. Please open a new bug if something similar happens again and I promise to take a look at it faster then I did with this report.

Note You need to log in before you can comment on or make changes to this bug.