Bug 1287196 - ospd-7: Could not restart Service[heat-engine]: Execution of '/usr/bin/systemctl restart openstack-heat-engine' returned 1
ospd-7: Could not restart Service[heat-engine]: Execution of '/usr/bin/system...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: James Slagle
Amit Ugol
: Automation, TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 12:53 EST by Steve Linabery
Modified: 2016-04-20 07:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 07:22:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error from /var/log/heat/heat-engine.log (71.62 KB, text/plain)
2015-12-01 12:53 EST, Steve Linabery
no flags Details

  None (edit)
Description Steve Linabery 2015-12-01 12:53:42 EST
Created attachment 1100978 [details]
error from /var/log/heat/heat-engine.log

Description of problem:
When testing latest poodle, overcloud deploy fails with this error in heat-engine-log. See attachment.
Comment 3 Steve Linabery 2015-12-01 12:56:34 EST
deploy cmd:
openstack overcloud deploy --debug --log-file overcloud_deployment_16.log --templates --libvirt-type=qemu --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server 10.5.26.10 --control-scale 1 --compute-scale 1 --ceph-storage-scale 1 --block-storage-scale 0 --swift-storage-scale 0 --control-flavor baremetal --compute-flavor baremetal --ceph-storage-flavor baremetal --block-storage-flavor baremetal --swift-storage-flavor baremetal --timeout=240 -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml -e ~/network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml
Comment 5 Zane Bitter 2015-12-01 14:02:12 EST
That log message appears on 100% of deployments, failed or not.

The actual error here is from Puppet:

ERROR heat.engine.resources.openstack.heat.software_deployment [-] Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6

And the cause was (coincidentally) failing to restart the *overcloud* Heat:

Error: /Stage[main]/Heat::Engine/Service[heat-engine]: Failed to call refresh: Could not restart Service[heat-engine]: Execution of '/usr/bin/systemctl restart openstack-heat-engine' returned 1: Job for openstack-heat-engine.service canceled.
Error: /Stage[main]/Heat::Engine/Service[heat-engine]: Could not restart Service[heat-engine]: Execution of '/usr/bin/systemctl restart openstack-heat-engine' returned 1: Job for openstack-heat-engine.service canceled.
Wrapped exception:
Execution of '/usr/bin/systemctl restart openstack-heat-engine' returned 1: Job for openstack-heat-engine.service canceled.
Comment 7 Amit Ugol 2016-03-22 02:37:06 EDT
unable to reproduce

Note You need to log in before you can comment on or make changes to this bug.