Bug 1287243 - RHEL-H won't install due to package conflict [NEEDINFO]
RHEL-H won't install due to package conflict
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
3.5.3
x86_64 Linux
high Severity urgent
: ovirt-3.5.8
: ---
Assigned To: Lev Veyde
integration
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 15:05 EST by Robert McSwain
Modified: 2016-02-01 02:34 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 02:34:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lveyde: needinfo? (rmcswain)
byount: needinfo? (rmcswain)


Attachments (Terms of Use)

  None (edit)
Description Robert McSwain 2015-12-01 15:05:23 EST
Description of problem:
Failed to install Host HOSTNAME. Failed to execute stage 'Package installation': ['qemu-kvm-rhev-tools conflicts with 2:qemu-kvm-tools-0.12.1.2-2.479.el6_7.2.x86_64'].

Version-Release number of selected component (if applicable):
rhevm-3.5.5-0.1.el6ev.noarch

How reproducible:
Unknown other than in customer's environment

Steps to Reproduce:
1. Install a RHEL system with 6.7 and subscribe it to the proper channels:
rhel-6-server-optional-rpms        Red Hat Enterprise Linux 6 Server - Op  9116
rhel-6-server-rhev-mgmt-agent-rpms Red Hat Enterprise Virtualization Mana   574
rhel-6-server-rpms                 Red Hat Enterprise Linux 6 Server (RPM 16324

2. Attempt to add the host from the RHEV-M Admin Portal

3. Observe the failure due to package conflict

2015-11-17 12:00:26 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum queue package qemu-kvm-tools for install
2015-11-17 12:00:27 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum processing package 2:qemu-kvm-tools-0.12.1.2-2.479.el6_7.
2.x86_64 for install
2015-11-17 12:00:27 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum package 2:qemu-kvm-tools-0.12.1.2-2.479.el6_7.2.x86_64 qu
eued
2015-11-17 12:00:27 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum queue package vdsm for install
2015-11-17 12:00:27 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum queue package vdsm-cli for install
2015-11-17 12:00:27 DEBUG otopi.context context._executeMethod:138 Stage packages METHOD otopi.plugins.ovirt_host_deploy.vdsm.pki.Plugin._packages
2015-11-17 12:00:27 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum queue package m2crypto for install
2015-11-17 12:00:27 DEBUG otopi.context context._executeMethod:138 Stage packages METHOD otopi.plugins.ovirt_host_deploy.vdsmhooks.hooks.Plugin._package
s
2015-11-17 12:00:27 DEBUG otopi.context context._executeMethod:138 Stage packages METHOD otopi.plugins.otopi.packagers.yumpackager.Plugin._packages
2015-11-17 12:00:27 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum Building transaction
2015-11-17 12:00:30 ERROR otopi.plugins.otopi.packagers.yumpackager yumpackager.error:97 Yum ['qemu-kvm-rhev-tools conflicts with 2:qemu-kvm-tools-0.12.
1.2-2.479.el6_7.2.x86_64']
2015-11-17 12:00:30 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/tmp/ovirt-NpIQ5RYCwZ/pythonlib/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/tmp/ovirt-NpIQ5RYCwZ/otopi-plugins/otopi/packagers/yumpackager.py", line 261, in _packages
    if self._miniyum.buildTransaction():
  File "/tmp/ovirt-NpIQ5RYCwZ/pythonlib/otopi/miniyum.py", line 917, in buildTransaction
    raise yum.Errors.YumBaseError(msg)
YumBaseError: ['qemu-kvm-rhev-tools conflicts with 2:qemu-kvm-tools-0.12.1.2-2.479.el6_7.2.x86_64']
2015-11-17 12:00:30 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Package installation': ['qemu-kvm-rhev-tools conflicts with 
2:qemu-kvm-tools-0.12.1.2-2.479.el6_7.2.x86_64']
2015-11-17 12:00:30 DEBUG otopi.transaction transaction.abort:131 aborting 'Yum Transaction'
2015-11-17 12:00:30 INFO otopi.plugins.otopi.packagers.yumpackager yumpackager.info:92 Yum Performing yum transaction rollback

4. Confirm that qemu-kvm-tools aren't installed:
rpm -qa|grep qemu|cut -c 1-50
gpxe-roms-qemu-0.9.7-6.14.el6.noarch              
qemu-img-rhev-0.12.1.2-2.479.el6_7.2.x86_64       
qemu-kvm-rhev-0.12.1.2-2.479.el6_7.2.x86_64       
qemu-kvm-rhev-tools-0.12.1.2-2.479.el6_7.2.x86_64 

Actual results:
Host fails to install

Expected results:
Host installs fine and can be added to RHEV

Additional info:
Customer data coming shortly
Comment 2 Alon Bar-Lev 2015-12-01 15:12:49 EST
Please confirm this conflict using standard yum:

# yum install qemu-kvm-tools

Please try to update manually host:

# yum update

Then again:

# yum install qemu-kvm-tools

Thanks!
Comment 3 Robert McSwain 2015-12-03 15:26:52 EST
Alon,

Thanks for the quick turnaround. That does work, as per my customer as a workaround:

1. yum install qemu-kvm-tools
2. RHEV-M gui -> Add host
3. Host installs correctly
Comment 4 Bryan Yount 2015-12-07 13:05:40 EST
The customer tried adding the host via RHEV-M and was getting a package conflict with qemu-kvm-rhev-tools. The only way to work around this was manually installing qemu-kvm-tools and then adding the host in RHEV-M. After he did that, the host installed correctly.

It seems like there's an issue with the dependency chain with qemu-kvm-rhev-tools or another related package.
Comment 6 Chao Yang 2015-12-09 21:00:45 EST
# rpm -qp --conflicts qemu-kvm-tools-0.12.1.2-2.481.el6.x86_64.rpm 
qemu-kvm-tools-rhev  

If you have qemu-kvm-tools-rhev installed already, trying to install qemu-kvm-tools will fail. This is expected cause they conflict with each other. 

If you have a repo that provides qemu-kvm-rhev related packages, rhev version of qemu-kvm would get installed. 

Please refer to the bug below for more information:
Bug 818620 - qemu-kvm-rhev should obsolete qemu-kvm
Comment 7 Jeff Nelson 2015-12-10 10:01:01 EST
This is expected behavior. qemu-kvm-tools and qemu-kvm-rhev-tools are supposed to conflict with each other.

According to the original description, something is trying to install qemu-kvm-tools, vdsm, vdsm-cli and m2crypto. Yum is correctly rejecting this because qemu-kvm-tools cannot coexist with qemu-kvm-rhev-tools.

Based on the traceback info, it appears that ovirt is responsible for this. Reassigning to ovirt team for further investigation.
Comment 10 Sandro Bonazzola 2015-12-23 07:09:34 EST
(In reply to Jeff Nelson from comment #7)
> This is expected behavior. qemu-kvm-tools and qemu-kvm-rhev-tools are
> supposed to conflict with each other.
> 
> According to the original description, something is trying to install
> qemu-kvm-tools, vdsm, vdsm-cli and m2crypto. Yum is correctly rejecting this
> because qemu-kvm-tools cannot coexist with qemu-kvm-rhev-tools.
> 
> Based on the traceback info, it appears that ovirt is responsible for this.
> Reassigning to ovirt team for further investigation.

Closing as not a bug
Comment 11 Bryan Yount 2016-01-18 20:00:43 EST
(In reply to Sandro Bonazzola from comment #10)
> (In reply to Jeff Nelson from comment #7)
> > This is expected behavior. qemu-kvm-tools and qemu-kvm-rhev-tools are
> > supposed to conflict with each other.
> > 
> > According to the original description, something is trying to install
> > qemu-kvm-tools, vdsm, vdsm-cli and m2crypto. Yum is correctly rejecting this
> > because qemu-kvm-tools cannot coexist with qemu-kvm-rhev-tools.
> > 
> > Based on the traceback info, it appears that ovirt is responsible for this.
> > Reassigning to ovirt team for further investigation.
> 
> Closing as not a bug

Reopening. I realize these packages are supposed to conflict with each other but it still doesn't explain why the customer, with a freshly built system, was unable to add it to RHEV-M as a Host. The "Add host" kept failing with the aforementioned package conflict. Can anyone reproduce this issue?
Comment 12 Sandro Bonazzola 2016-01-19 10:17:38 EST
Moving from node to host-deploy, this affecting RHEL-H and not RHEV-H
Comment 13 Sandro Bonazzola 2016-01-19 10:19:54 EST
(In reply to Sandro Bonazzola from comment #12)
> Moving from node to host-deploy, this affecting RHEL-H and not RHEV-H

sorry, moving to distribution, not being something related to ovirt-host-deploy directly.
Comment 14 Sandro Bonazzola 2016-01-19 10:24:22 EST
Lev, can you dig into this? It doesn't reproduce on standard install from scratch for me. 
Can you dig into customer environment configuration and help solving the issue?
Comment 15 Lev Veyde 2016-01-20 01:44:48 EST
(In reply to Sandro Bonazzola from comment #14)
> Lev, can you dig into this? It doesn't reproduce on standard install from
> scratch for me. 
> Can you dig into customer environment configuration and help solving the
> issue?

Will try to reproduce.
Comment 16 Lev Veyde 2016-01-20 10:40:42 EST
Couldn't reproduce this.

Used a clean RHEL 6.7 x86_64 installation.

The channels that were added are:
rhel-x86_64-rhev-mgmt-agent-6    Red Hat Enterprise Virt Management Agent (v.6 for x86_64)    546
rhel-x86_64-server-6    Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)    16,486
rhel-x86_64-server-optional-6    RHEL Server Optional (v. 6 64-bit x86_64)    9,305

Note You need to log in before you can comment on or make changes to this bug.