Bug 1287261 - rhel-osp-director: undercloud restoration from backup: "openstack undercloud install" exits with error: "Conflict: Unable to create the flat network. Physical network ctlplane is in use."
rhel-osp-director: undercloud restoration from backup: "openstack undercloud ...
Status: CLOSED DUPLICATE of bug 1272302
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 15:41 EST by Alexander Chuzhoy
Modified: 2016-04-18 02:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 08:25:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from the undercloud node (9.36 MB, application/x-gzip)
2015-12-01 16:23 EST, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-12-01 15:41:11 EST
rhel-osp-director: undercloud restoration from backup: "openstack undercloud install" exits with error: "Conflict: Unable to create the flat network. Physical network ctlplane is in use."

Environment:
instack-undercloud-2.1.2-22.el7ost.noarch

Steps to reproduce:

Follow the procedure to restore the undercloud:
https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/7/back-up-and-restore-red-hat-enterprise-linux-openstack-platform/chapter-2-restore


Result:
The step "openstack undercloud install" exits with error:

[2015/12/01 03:15:38 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json                                                                                                       
+ NETWORK_CIDR=192.0.2.0/24                                                                                                                                                                                          
++ os-apply-config --key neutron.network_gateway --type netaddress                                                                                                                                                   
[2015/12/01 03:15:39 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json                                                                                                       
+ NETWORK_GATEWAY=192.0.2.1                                                                                                                                                                                          
+ METADATA_SERVER=192.0.2.1                                                                                                                                                                                          
+ PHYSICAL_NETWORK=ctlplane                                                                                                                                                                                          
++ mktemp                                                                                                                                                                                                            
+ NETWORK_JSON=/tmp/tmp.bNWdikXDCI                                                                                                                                                                                   
+ NETWORK_JSON_DATA='{"physical":{}}'                                                                                                                                                                                
++ jq '.physical = .physical + {                                                                                                                                                                                     
    "gateway": "192.0.2.1",                                                                                                                                                                                          
    "metadata_server": "192.0.2.1",                                                                                                                                                                                  
    "cidr": "192.0.2.0/24",                                                                                                                                                                                          
    "allocation_start": "192.0.2.5",                                                                                                                                                                                 
    "allocation_end": "192.0.2.24",                                                                                                                                                                                  
    "name": "ctlplane",                                                                                                                                                                                              
}'                                                                                                                                                                                                                   
+ NETWORK_JSON_DATA='{                                                                                                                                                                                               
  "physical": {                                                                                                                                                                                                      
    "gateway": "192.0.2.1",                                                                                                                                                                                          
    "metadata_server": "192.0.2.1",                                                                                                                                                                                  
    "cidr": "192.0.2.0/24",                                                                                                                                                                                          
    "allocation_start": "192.0.2.5",                                                                                                                                                                                 
    "allocation_end": "192.0.2.24",                                                                                                                                                                                  
    "name": "ctlplane"                                                                                                                                                                                               
  }                                                                                                                                                                                                                  
}'                                                                                                                                                                                                                   
+ '[' -n '' ']'                                                                                                                                                                                                      
+ jq .                                                                                                                                                                                                               
+ setup-neutron -n /tmp/tmp.bNWdikXDCI                                                                                                                                                                               
2015-12-01 15:15:40 - root - ERROR - Unexpected error during command execution                                                                                                                                       
Traceback (most recent call last):                                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/os_cloud_config/cmd/setup_neutron.py", line 77, in main                                                                                                                     
    keystone_client=keystone_client)                                                                                                                                                                                 
  File "/usr/lib/python2.7/site-packages/os_cloud_config/neutron.py", line 46, in initialize_neutron                                                                                                                 
    net = _create_net(neutron_client, network_desc, network_type, admin_tenant)                                                                                                                                      
  File "/usr/lib/python2.7/site-packages/os_cloud_config/neutron.py", line 95, in _create_net                                                                                                                        
    return neutron.create_network({'network': network})                                                                                                                                                              
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 102, in with_params                                                                                                                     
    ret = self.function(instance, *args, **kwargs)                                                                                                                                                                   
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 571, in create_network                                                                                                                  
    return self.post(self.networks_path, body=body)                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 298, in post                                                                                                                            
    headers=headers, params=params)                                                                                                                                                                                  
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 211, in do_request                                                                                                                      
    self._handle_fault_response(status_code, replybody)                                                                                                                                                              
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 185, in _handle_fault_response                                                                                                          
    exception_handler_v20(status_code, des_error_body)                                                                                                                                                               
  File "/usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py", line 70, in exception_handler_v20                                                                                                            
    status_code=status_code)                                                                                                                                                                                         
Conflict: Unable to create the flat network. Physical network ctlplane is in use.                                                                                                                                    
[2015-12-01 15:15:40,883] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]                  

[2015-12-01 15:15:40,884] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):                               
  File "<string>", line 1, in <module>                           
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 526, in install
    _run_orc(instack_env)                                                                       
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 461, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')                                    
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 297, in _run_live_command
    raise RuntimeError('%s failed. See log for details.', name)                                           
RuntimeError: ('%s failed. See log for details.', 'os-refresh-config')
ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1



Expected result:

Successful undercloud deployment.
Comment 2 Alexander Chuzhoy 2015-12-01 16:23 EST
Created attachment 1101088 [details]
logs from the undercloud node
Comment 3 James Slagle 2015-12-04 08:25:21 EST

*** This bug has been marked as a duplicate of bug 1272302 ***

Note You need to log in before you can comment on or make changes to this bug.