Bug 1287265 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 955: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:75559700651b9dccf161707d198...
: EasyFix, i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 15:48 EST by florin78
Modified: 2016-08-01 04:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 04:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (225.74 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: _var_tmp_dnf-florin-185lp_ge_dnf.rpm.log (102.12 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: _var_tmp_dnf-florin-di7ii61a_dnf.librepo.log (57.51 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: _var_tmp_dnf-florin-di7ii61a_dnf.log (4.09 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: _var_tmp_dnf-florin-di7ii61a_hawkey.log (5.59 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: backtrace (2.05 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: dnf-makecache.log (159.66 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details
File: environ (1.55 KB, text/plain)
2015-12-01 15:48 EST, florin78
no flags Details

  None (edit)
Description florin78 2015-12-01 15:48:28 EST
Version-Release number of selected component:
dnf-1.1.4-1.fc23

Additional info:
reporter:       libreport-2.6.3
_var_tmp_dnf-florin-di7ii61a_dnf.rpm.log: Nov 20 21:40:34 INFO --- logging initialized ---
cmdline:        /usr/bin/python3 -OO /usr/bin/dnf repoquery -i google-noto-cjk-fonts
executable:     /usr/bin/dnf
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 955: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/repoquery.py", line 402, in run
    print(pkg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\u2014' in position 955: ordinal not in range(128)

Local variables in innermost frame:
s: 'Name        : google-noto-cjk-fonts\nVersion     : 1.004\nRelease     : 3.fc23\nArchitecture: noarch\nSize        : 84579298\nLicense     : OFL\nSource RPM  : google-noto-cjk-fonts-1.004-3.fc23.src.rpm\nBuild Date  : 2015-11-20 06:00\nPackager    : Fedora Project\nURL         : https://github.com/googlei18n/noto-cjk\nSummary     : Google Noto Sans CJK Fonts\nDescription :\nNoto Sans CJK is a sans serif typeface designed as an intermediate style\nbetween the modern and traditional.\nIt is intended to be a multi-purpose digital font for user interface designs,\ndigital content, reading on laptops, mobile devices, and electronic books.\nNoto Sans CJK comprehensively covers Simplified Chinese, Traditional Chinese,\nJapanese, and Korean in a unified font family.\nIt supports regional variants of ideographic characters for each of\nthe four languages.\nIn addition, it supports Japanese kana, vertical forms, and variant characters\n(itaiji); it supports Korean hangeul — both contemporary and archaic.\n'
self: <dnf.i18n.UnicodeStream object at 0x7f67b8926080>
Comment 1 florin78 2015-12-01 15:48:40 EST
Created attachment 1101041 [details]
File: _var_log_dnf.log
Comment 2 florin78 2015-12-01 15:48:44 EST
Created attachment 1101042 [details]
File: _var_tmp_dnf-florin-185lp_ge_dnf.rpm.log
Comment 3 florin78 2015-12-01 15:48:48 EST
Created attachment 1101043 [details]
File: _var_tmp_dnf-florin-di7ii61a_dnf.librepo.log
Comment 4 florin78 2015-12-01 15:48:49 EST
Created attachment 1101044 [details]
File: _var_tmp_dnf-florin-di7ii61a_dnf.log
Comment 5 florin78 2015-12-01 15:48:51 EST
Created attachment 1101045 [details]
File: _var_tmp_dnf-florin-di7ii61a_hawkey.log
Comment 6 florin78 2015-12-01 15:48:52 EST
Created attachment 1101046 [details]
File: backtrace
Comment 7 florin78 2015-12-01 15:48:58 EST
Created attachment 1101047 [details]
File: dnf-makecache.log
Comment 8 florin78 2015-12-01 15:48:59 EST
Created attachment 1101048 [details]
File: environ
Comment 9 Fedora Admin XMLRPC Client 2016-07-08 05:34:02 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Štěpán Smetana 2016-08-01 04:43:23 EDT
Works for me.
Should be fixed in dnf-1.1.9 (Take a look at this commit https://github.com/rpm-software-management/dnf/commit/93159e360f0b6150e598bba783e22ca113201a40)
In case reopen this bug.
Thanks

Note You need to log in before you can comment on or make changes to this bug.