Bug 1287283 - The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab
Summary: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by rep...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-reportlab
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: William Moreno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-01 21:31 UTC by Sjoerd Mullender
Modified: 2016-05-07 12:10 UTC (History)
5 users (show)

Fixed In Version: python-reportlab-3.3.0-1.fc23 python-reportlab-3.3.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-24 05:21:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Sjoerd Mullender 2015-12-01 21:31:08 UTC
Description of problem:
Running rst2pdf results in a stack trace, the gist of which is in the summary.
I have python-pillow (and also python3-pillow) installed.

Version-Release number of selected component (if applicable):
rst2pdf-0.93-6.fc23.noarch
python-pillow-3.0.0-1.fc23.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Run rst2pdf (no argument needed)
2.
3.

Actual results:
Python stack trace.

Expected results:
No stack trace.

Additional info:
This is the full stack trace:

Traceback (most recent call last):
  File "/usr/bin/rst2pdf", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab

Comment 1 Sergio Pascual 2015-12-02 12:49:22 UTC
Can you reproduce this problem in F22?

Comment 2 Sjoerd Mullender 2015-12-02 12:54:10 UTC
On F22 it seems to work correctly.

Comment 3 Sergio Pascual 2015-12-02 12:56:44 UTC
Oh, this is known reportlab bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1267446

But is not fixed in f23

Comment 4 Lenz Grimmer 2016-01-05 17:33:08 UTC
Shouldn't this bug be closed as a duplicate of bug#1267446 then?

Comment 5 Sergio Pascual 2016-01-11 00:10:39 UTC
The other is in rawhide, this is f23

Comment 6 Fedora Admin XMLRPC Client 2016-02-26 18:08:04 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Fedora Update System 2016-04-11 15:13:51 UTC
python-reportlab-3.3.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-62bb566860

Comment 8 Fedora Update System 2016-04-11 15:14:13 UTC
python-reportlab-3.3.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8237eeb5d

Comment 9 Fedora Update System 2016-04-12 10:52:49 UTC
python-reportlab-3.3.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8237eeb5d

Comment 10 Fedora Update System 2016-04-13 09:27:26 UTC
python-reportlab-3.3.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-62bb566860

Comment 11 Fedora Update System 2016-04-24 05:21:12 UTC
python-reportlab-3.3.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-05-07 12:10:34 UTC
python-reportlab-3.3.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.