Bug 1287439 - [Docs] [Director] Invalid repos for beta liberty release
[Docs] [Director] Invalid repos for beta liberty release
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: beta
: 8.0 (Liberty)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 01:05 EST by Qasim Sarfraz
Modified: 2016-04-05 02:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 02:44:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qasim Sarfraz 2015-12-02 01:05:45 EST
Description of problem:

While following the deployment guide for rhel-osp8 beta, following repos need to be enabled on rhel-osp director:

- rhel-7-server-openstack-8.0-rpms
- rhel-7-server-openstack-8.0-director-rpms

Currently, these are invalid repositories.

Version-Release number of selected component (if applicable): 8

Steps to Reproduce:
1. Install rhel-osp 8 director using beta guide
2. This issue will be reproduced in section 3.4

Actual results:
Error: rhel-7-server-openstack-8.0-rpms is not a valid repository ID. Use --list option to see valid repositories.
Error: rhel-7-server-openstack-8.0-director-rpms is not a valid repository ID. Use --list option to see valid repositories.

Expected results:
Repository 'rhel-7-server-openstack-8.0-rpms' is enabled for this system.
Repository 'rhel-7-server-openstack-8.0-director-rpms' is enabled for this system.

Additional info:
As a workaround, repos from partner ftp server needs to be enabled on director.
Comment 2 Mike Burns 2015-12-02 07:50:34 EST
For beta, you replace the rhel-7-server-openstack-8.0-*-rpms repos with the repos from the FTP site (or to a local mirror of the ftp site repos).  

I'll leave this open so we can update the docs
Comment 3 Andrew Dahms 2015-12-07 17:58:12 EST
Assigning to Dan for review.
Comment 4 Dan Macpherson 2016-04-05 02:44:03 EDT
Since GA is around the corner, I won't be fixing for the beta release.

Note You need to log in before you can comment on or make changes to this bug.