Bug 1287472 - [REGENERATE JAVA SDK] cluster.getManagementNetwork() returns Null
[REGENERATE JAVA SDK] cluster.getManagementNetwork() returns Null
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-sdk-java
Classification: oVirt
Component: Core (Show other bugs)
3.6.0.3
x86_64 Linux
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2.0
Assigned To: Juan Hernández
Meni Yakove
: Automation
Depends On: 1287688
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 03:02 EST by Meni Yakove
Modified: 2016-02-18 06:13 EST (History)
2 users (show)

See Also:
Fixed In Version: ovirt-engine-sdk-java-3.6.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:13:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
juan.hernandez: ovirt‑3.6.z?
myakove: testing_plan_complete+
myakove: planning_ack?
juan.hernandez: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Meni Yakove 2015-12-02 03:02:20 EST
Description of problem:
cluster.getManagementNetwork() return Null 

Version-Release number of selected component (if applicable):
3.6.0.3.1-1

How reproducible:
100%

Steps to Reproduce:
Clusters clusters = api.getClusters();
for (Cluster cluster : clusters.list()) {
    System.out.println("\t Name :" + cluster.getName()); 
    System.out.println("\t MN : " + cluster.getManagementNetwork()); 
    }

Actual results:
return Null

Expected results:
return Management network
Comment 1 Juan Hernández 2015-12-02 08:30:27 EST
Moving to infra till I can determine if it is a SDK or engine issue.
Comment 2 Juan Hernández 2015-12-02 09:05:33 EST
The management network isn't populated unless the "All-Content: true" header is included in the request. And this is currently impossible because it isn't documented in the RSDL document, and thus there isn't a method in the SDK that has this as a parameter.

Once it is fixed in the engine then the SDK will need to be regenerated, and it should be possible to use it with the "list" method that receives it as a parameter, something like this:

  clusters.list(
    null, // query
    null, // caseSensitive
    null, // max
    true  // allContent
  )
Comment 3 Yaniv Kaul 2015-12-03 10:01:23 EST
(In reply to Juan Hernández from comment #2)
> The management network isn't populated unless the "All-Content: true" header
> is included in the request. And this is currently impossible because it
> isn't documented in the RSDL document, and thus there isn't a method in the
> SDK that has this as a parameter.

Is there a bug on this?
Comment 4 Juan Hernández 2015-12-03 11:58:41 EST
Yes, bug 1287688, which blocks this bug.
Comment 5 Sandro Bonazzola 2015-12-23 08:40:52 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA

Note You need to log in before you can comment on or make changes to this bug.