Bug 1287476 - Met "'/bin/sh -c scl enable ror40 "bundle install"' returned a non-zero code: 1" when docker build with ruby-22 and source repo ruby-hello-world
Met "'/bin/sh -c scl enable ror40 "bundle install"' returned a non-zero code:...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Build (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ben Parees
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 03:13 EST by Wenjing Zheng
Modified: 2016-05-12 13:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:10:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2015-12-02 03:13:11 EST
Description of problem:
Met such error '/bin/sh -c scl enable ror40 "bundle install"' returned a non-zero code: 1 when use default application-template-dockerbuild.json under origin repo. Since it is changed to build with ruby-22 which not support "scl enable ror40", if change it to scl enable rh-ruby22 "bundle install", no such error for sti build.

Version-Release number of selected component (if applicable):
https://raw.githubusercontent.com/openshift/ruby-hello-world/master/Dockerfile

How reproducible:
always

Steps to Reproduce:
1. Create a project
2. oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-dockerbuild.json
3. Check build status and build log

Actual results:
Build goes failed due to this error:
'/bin/sh -c scl enable ror40 "bundle install"' returned a non-zero code: 1 

Expected results:
Build should succeed like using ruby-20 image; if plan to use ruby-22 in the sample json file, dockerfile in ruby-hello-world should be changed like line 7,8: https://github.com/wanghaoran1988/ruby-hello-world/blob/master/Dockerfile

Additional info:
Comment 1 Ben Parees 2015-12-02 08:00:51 EST
Thanks, fixed here:

https://github.com/openshift/ruby-hello-world/pull/49
Comment 2 Wenjing Zheng 2015-12-03 02:13:57 EST
Verified with update dockerfile, works now, thanks!
openshift v3.1.0.4-16-g112fcc4
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

Note You need to log in before you can comment on or make changes to this bug.