Bug 1287478 - [RFE] add support for external puppet master
[RFE] add support for external puppet master
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 03:21 EST by Veaceslav Mindru
Modified: 2016-09-30 04:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-30 04:11:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veaceslav Mindru 2015-12-02 03:21:32 EST
RFE:

OSP7 is missing support for an external puppet master.
This is preventing Satelite and Foreman to be used along with OSP7.


VM
Comment 2 Graeme Gillies 2015-12-02 17:31:09 EST
I've done part of the work of making the puppet heat hook more friendly to existing puppet configurations, but more needs to be done. Then this needs to be validated (likely with satellite 6).
Comment 4 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Jaromir Coufal 2016-09-30 04:11:26 EDT
Director will not allow external puppet to configure services since it would lose control of the content and configuration on the nodes.

Note You need to log in before you can comment on or make changes to this bug.