Bug 128748 - net-snmp-config tells that he needs libelf which isn't needed
net-snmp-config tells that he needs libelf which isn't needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Radek Vokal
http://www.fwbuilder.org/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-28 18:05 EDT by Marcel Nijenhof
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 07:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Nijenhof 2004-07-28 18:05:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
If i run net-snmp-config i get:
  # ./usr/bin/net-snmp-config --libs
  -L/usr/lib -lnetsnmp -lcrypto -lelf -lm

I tryed to compile libfwbuilder which refused to compile with snmp
support because it couldn't use the libelf.

NOTE:
  I have changed "/usr/bin/net-snmp-config" so that it didn't output
  "-lelf" and i was able to compile fwbuilder 2 with snmp support.


Version-Release number of selected component (if applicable):
net-snmp-devel-5.1.1-2

How reproducible:
Always

Steps to Reproduce:
1. Run "/usr/bin/net-snmp-config" and see that it shows -lelf
2. Run the "./configure" from libfwbuilder and see that it refuses to
   compile with snmp support.
3. Check the config.log

NOTE:
  I don't have "elfutils-libelf-devel" installed but this isn't a
  dependcy so it should work. And i don't no if that solves te
  problem
    

Actual Results:  [root@dame libfwbuilder-2.0.0]# ./configure
....
Support for SNMP queries  :                              NO
...

The config.log says:
configure:6209: gcc -o conftest -g -O2   conftest.c -lnetsnmp
-L/usr/lib -lnetsnmp -lcrypto -lelf -lm -lcrypto  >&5
/usr/bin/ld: cannot find -lelf


Expected Results:  It should have compiled libfwbuilder with snmp
support. After my patch
as described in "Additional Information":

Support for SNMP queries  :                              YES
    Using ucd_snmp library :                             NO
    Using net_snmp library :                             YES


Additional info:

I have changed "net-snmp-config" so that it doesn't tell to use libelf
after which it worked.

The diference:

# diff /usr/bin/net-snmp-config.org /usr/bin/net-snmp-config
34,35c34,35
< NSC_LIBS="-lcrypto -lelf -lm "
< NSC_AGENTLIBS="-ldl -lrpm -lrpmio -lpopt  -lbz2 -lz -lcrypto -lelf -lm "
---
> NSC_LIBS="-lcrypto -lm "
> NSC_AGENTLIBS="-ldl -lrpm -lrpmio -lpopt  -lbz2 -lz -lcrypto -lm "
Comment 1 Radek Vokal 2004-09-08 07:13:55 EDT
Will be fixed in rawhide net-snmp-5.1.2-4

Note You need to log in before you can comment on or make changes to this bug.