Bug 128753 - RHEL4 Alpha 4 parm file space limitation workaround for mainframe
RHEL4 Alpha 4 parm file space limitation workaround for mainframe
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-28 19:05 EDT by dff
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 18:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dff 2004-07-28 19:05:19 EDT
Due to kernel limits and space limitations of the .parm file, a new
config file on a CMS DASD should be used to configure the initial
network setup and the DASDs.

A .parm file is still required for the 'real' kernel parameters such as

   root=/dev/ram0 ro ip=off ramdisk_size=40000

and single parameters which aren't assigned to variables such as 'vnc'
Two new parameters which point the installer at the new config file
need to be added to the .parm file:

   CMSDASD=191 CMSCONFFILE=redhat.conf

CMSDASD is the device id of the CMS formatted DASD which contains the
config file. CMSDASD is usually the '$HOME' DASD 191 of the mainframe
user.  The name of the config file needs to be set with CMSCONFFILE
and needs to be all lowercase.

The syntax of the CMSCONFFILE is bash style with variable="value"
pairs, one on each line.  The valid variable names are the same as
those from the old .parm files (RHEL3)

Example redhat.parm file:
root=/dev/ram0 ro ip=off ramdisk_size=40000
CMSDASD=191 CMSCONFFILE=redhat.conf
vnc

Example redhat.exec file:
/* */                    
'cl rdr'                 
'purge rdr all'          
'spool punch * rdr'      
'PUNCH KERNEL IMG A (NOH'
'PUNCH REDHAT PARM A (NOH'
'PUNCH INITRD IMG A (NOH'
'ch rdr all keep nohold' 
'i 00c'                  

Example redhat.conf file:
HOSTNAME="spade.z900.redhat.com"
DASD="200-203"
NETTYPE="eth"
IPADDR="192.168.5.115"
SUBCHANNELS="0.0.0600,0.0.0601,0.0.0602"
PORTNAME="FOOBAR"
NETWORK="192.168.5.0"
NETMASK="255.255.255.0"
BROADCAST="192.168.5.255"
SEARCHDNS="redhat.com:z900.redhat.com"
GATEWAY="192.168.5.254"
DNS="192.168.5.1"
MTU="4096"

Note You need to log in before you can comment on or make changes to this bug.