Bug 128755 - workplace switcher doe not work properly in metacity, or sawfish
workplace switcher doe not work properly in metacity, or sawfish
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libwnck (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-28 20:06 EDT by Net Nut
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 08:16:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Net Nut 2004-07-28 20:06:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The workplace switcher does not function properly.
First off when using metacity as your window managed you can not see
the windows that are on other workplaces. (the moment you swith to
another workplace your view of the contents of the previous workplace
disapears then making you guess where you left your other windows.

Second if you switch to sawfish for better workplace edgeflipping
functionality, you will find that edgeflipping works fine on your
workplaces, but if you click anywhere in the workplace switcher (to
select a different workplace) all the windows that are open on all
desktops get moved around to where there are only small portions of
the window available on each desktop.  I should mention that the
workplaces are displayed correctly when using sawfish unlike metacity
untill you make the mistake of clicking on the switcher (like you
should be able to to).  This is compleatley reproduceable as I have
done this on 4 fedora machines.

Version-Release number of selected component (if applicable):
gnome-applets-2.6.2.1-1

How reproducible:
Always

Steps to Reproduce:
setup multiple desktops  (I chose 9 in rows of 3 )  using metacity you
will only be able to see the windows on your current workplace.

switch to sawfish ( "killall metacity; wait ; sawfish &" works for me)

open some windows on different desktops without using the workplace
switcher (<shift> <control> <alt> <arrow keys> to move a window
arround ) you can now see things on your desktops..  

now click on the workplace switcher, and watch all your windows move
haywire over all the desktops..  

Result.. not fun..  you have to reposition all your windows manaully
again, and remind yourself not to use the workplace switcher.

 
    

Actual Results:  you have to reposition all your windows manaully
again, and remind yourself not to use the workplace switcher.


Expected Results:  being able to view and switch to different
workplaces effortlessly.

Additional info:
Comment 1 Mark McLoughlin 2004-07-29 04:09:34 EDT
(Applet is in gnome-panel really, but core functionality implemented
by libwnck)

Issue with sawfish is a dup of bug #120652 - update to
libwnck-2.6.0.1-3 for the fix.

Issue with metacity is very strange, I've never seen that - your going
to need to give more information:

  - Does this happen with a new user? Could you try adding a test
    user, logging in as that test user and try and reproduce?

  - Any special preferences set? You could attach the gconftool-2 -R
    output for

      /apps/panel/profiles/default/applets/workspace_switcher/prefs
      /apps/metacity

Comment 2 Mark McLoughlin 2004-12-20 08:16:48 EST
No response, closing

Note You need to log in before you can comment on or make changes to this bug.