Bug 1287604 - KieScanner not scanning custom maven repository from web app (Cool Store)
KieScanner not scanning custom maven repository from web app (Cool Store)
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Mario Fusco
Marek Winkler
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 07:22 EST by Eric D. Schabell
Modified: 2015-12-03 04:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 04:50:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric D. Schabell 2015-12-02 07:22:39 EST
Description of problem:
Regression of problem described in https://bugzilla.redhat.com/show_bug.cgi?id=1217295, same behavior with brms 6.2.CR2, logs shows scanner picking up project updates when build&deployed, but app not leveraging updates.

Project can be found on https://github.com/jbossdemocentral/brms-coolstore-demo/tree/6.2

Version-Release number of selected component (if applicable): brms 6.2.CR2


How reproducible: see Readme in project and bug 1217295, install project, build and deploy in business central, access web app, first initial pricing when adding <$25 is 2.99, then update guided decision table pricing rules so 0-25 is 12.99, save, build and deploy (tried without version bump and with version bump), see log KieScanner reports finding new version, re-try same item in web app shopping cart and no new pricing. 

To see proper usage, take master branch based on brms 6.1.1 (patched), this works properly for above scenario.


Steps to Reproduce:
1. see above
2.
3.

Actual results:
no new pricing used as described above, shows $2.99 shipping costs.

Expected results:
new pricing should be used, as noted above in example should be $12.99 for shipping costs.

Additional info:
Worked with  Alessandro Lazarotti last time on this.
Comment 2 Marek Winkler 2015-12-02 07:59:02 EST
Hi Eric,

I am trying to reproduce the issue, I noticed that you replaced the property 'kie.maven.settings.custom' with 'org.guvnor.m2repo.dir' in standalone.xml - please see [1]. Was this intentional? I am asking because this could have impact on KIE-Scanner.

I am currently following your instructions to reproduce it, will let you know the results hopefully in a couple of minutes.

Thanks,

Marek

[1] https://github.com/jbossdemocentral/brms-coolstore-demo/commit/3bc06f19330292ac873bb8055deeb38ce8c78571#diff-715268aa5e98482a75357fd7d4693cf8L36
Comment 3 Eric D. Schabell 2015-12-02 08:25:00 EST
(In reply to Marek Winkler from comment #2)
> Hi Eric,
> 
> I am trying to reproduce the issue, I noticed that you replaced the property
> 'kie.maven.settings.custom' with 'org.guvnor.m2repo.dir' in standalone.xml -
> please see [1]. Was this intentional? I am asking because this could have
> impact on KIE-Scanner.
> 
> I am currently following your instructions to reproduce it, will let you
> know the results hopefully in a couple of minutes.
> 
> Thanks,
> 
> Marek
> 
> [1]
> https://github.com/jbossdemocentral/brms-coolstore-demo/commit/
> 3bc06f19330292ac873bb8055deeb38ce8c78571#diff-
> 715268aa5e98482a75357fd7d4693cf8L36
>
Good catch, re-testing now.
Comment 5 Marek Winkler 2015-12-02 09:52:11 EST
I managed to make the demo work as expected, I had to:

 1. update the BxMS version: <jboss.brms.version>6.2.0.GA-redhat-1</jboss.brms.version>

 2. since the demo app is using a kjar which includes Guided Decision Tables, the demo app must include the following dependency (new in BxMS 6.2 - I think this should be documented!):

  <dependency>
    <groupId>org.drools</groupId>
    <artifactId>drools-workbench-models-guided-dtable</artifactId>
  </dependency>

 3. add missing kie.maven.settings.custom property to standalone.xml.

The shipping cost in the demo app gets updated when I change it in business-central and build and deploy the project.

I have created a PR [1] with the above changes, please re-test and let me know if there are any issues, thanks! If it works for you, we could close this BZ.

[1] https://github.com/jbossdemocentral/brms-coolstore-demo/pull/41
Comment 7 Eric D. Schabell 2015-12-02 11:11:13 EST
Applied PR, testing but when changes made to decision table, getting no rules applied to shipping and it remains $0. Should be the new adjusted shipping price.

The maven repo is not setup in /tmp/maven-repo/* correctly, the scanner says in log it picks up new initial builds and also if bumping the 2.0.0 -> 3.0.0 (or any other version)... 

Same behavior still as reported.

Note You need to log in before you can comment on or make changes to this bug.