Bug 1287609 - Race condition on property filter
Race condition on property filter
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
1.2
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: candlepin-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 07:42 EST by Filip Nguyen
Modified: 2016-07-22 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 10:39:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Nguyen 2015-12-02 07:42:06 EST
Description of problem:
In Satellite, some clients are issuing GET to this url [1] to get entitlements. Sometimes these calls fail with [2]. Looking at logs (such as in attached customer case) it seems that problem is Race condition in our DynamicPropertyFilter that is not thread safe.

Its hard to judge the impact of this, customer issue was solved by reindex. But its possible it was caused by this.

[1] /candlepin/consumers/<UUID>/entitlements?exclude=certificates.key&exclude=certificates.cert

[2]
Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 3

Version-Release number of selected component (if applicable):
0.9, but the same code is in master

How reproducible:
hard

Steps to Reproduce:
No easy reproducer here.
1. Just call /candlepin/consumers/<UUID>/entitlements?exclude=certificates.key&exclude=certificates.cert simultaneuously

Actual results:
sometimes you get org.candlepin.common.exceptions.mappers.CandlepinExceptionMapper - Runtime Error com.fasterxml.jackson.databind.JsonMappingException: Index: 0, Size: 3

Expected results:
Returned list of Entitlements

Additional info:
Comment 2 Mike McCune 2016-03-28 18:23:05 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Barnaby Court 2016-07-22 10:39:20 EDT
Moving to closed per the updated candlepin process for bugs that have been merged or have been taken care of.

Note You need to log in before you can comment on or make changes to this bug.