Bug 128766 - japanese manpage is unreadable
japanese manpage is unreadable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-29 06:20 EDT by Hisaya FUKUMOTO
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 10:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the man page in kterm (11.70 KB, image/png)
2004-07-29 12:41 EDT, Nils Philippsen
no flags Details
reconverted man page (936 bytes, application/x-troff-man)
2004-07-29 16:09 EDT, Nils Philippsen
no flags Details
replace "dateconfig" to "system-config-date" (992 bytes, application/x-troff-man)
2004-07-30 04:43 EDT, Hisaya FUKUMOTO
no flags Details

  None (edit)
Description Hisaya FUKUMOTO 2004-07-29 06:20:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6) Gecko/20040627

Description of problem:
'ja/man8/system-config-date.8.gz' is unreadble.

Version-Release number of selected component (if applicable):
system-config-date-1.7.3-3

How reproducible:
Always

Steps to Reproduce:
1.export LANG=ja_JP.UTF-8
2.man 8 system-config-date


Actual Results:  displayed 'system-config-date' manpage, but unreadble
character.


Additional info:
Comment 1 Nils Philippsen 2004-07-29 09:24:24 EDT
Which terminal program do you use? I tried it with gnome-terminal and
kterm, with gnome-terminal I got some gibberish special characters but
with kterm I got something that looked to me (I don't speak Japanese
nor can I read or write it) like Japanese characters.

Please check whether this is the same with you.
Comment 2 Hisaya FUKUMOTO 2004-07-29 09:56:45 EDT
I used gnome-terminal and mlterm.
The gibberish special characters is not Japanese characters.
That's manpage not written by Japanese or misconvert other charset.
Comment 3 Nils Philippsen 2004-07-29 10:24:46 EDT
I don't know about mlterm, but please try whether you can reproduce
the problem in kterm. I am trying to determine whether it's a problem
of the man page or the terminal emulation.
Comment 4 Hisaya FUKUMOTO 2004-07-29 11:05:24 EDT
I tryed with kterm, same as result.
I expand 'system-config-date.8.gz' and open 'system-config-date.8'
with emacs, the manpage was not written by Japanese.
Comment 5 Nils Philippsen 2004-07-29 12:41:09 EDT
Created attachment 102288 [details]
Screenshot of the man page in kterm
Comment 6 Nils Philippsen 2004-07-29 12:42:17 EDT
Please check the screenshot I just attached whether this is readable
for you or not -- it looks like Japanese characters to me, but I'm not
sure ;-).
Comment 7 Hisaya FUKUMOTO 2004-07-29 13:30:49 EDT
The screenshot is same as my result.
I checkout the source code from system-config-date's cvs repository,
and view japanese manpage with emacs.
That's file not written by Japanese.
I guess that misconverted or broken file.
Comment 8 Nils Philippsen 2004-07-29 16:09:06 EDT
Created attachment 102300 [details]
reconverted man page
Comment 9 Nils Philippsen 2004-07-29 16:11:07 EDT
Hi,

I took the old non-UTF-8 man page and converted it again, then
substituted "dateconfig" with "system-config-date". Please check
whether this one displays well.
Comment 10 Hisaya FUKUMOTO 2004-07-29 23:15:55 EDT
I checked the manpage of attachement, it's displayed well.
I guess that the bug#128767 (system-config-kickstart.8) is same problem.
Comment 11 Nils Philippsen 2004-07-30 03:50:21 EDT
Is the information contained up to date? I mean, does it say roughly
the same as the English man page? I wouldn't want to issue an update
if the information in the man page is obsolete.
Comment 12 Hisaya FUKUMOTO 2004-07-30 04:33:56 EDT
It's same contents as the English man page, except program name is
"dateconfig".
Comment 13 Hisaya FUKUMOTO 2004-07-30 04:43:18 EDT
Created attachment 102314 [details]
replace "dateconfig" to "system-config-date"
Comment 14 Nils Philippsen 2004-08-11 10:50:58 EDT
A fixed package should appear in updates shortly.

Note You need to log in before you can comment on or make changes to this bug.