Bug 1287665 - NPE in VdsNetworkInterface
NPE in VdsNetworkInterface
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.1
: 3.6.1.2
Assigned To: Martin Mucha
Meni Yakove
network
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 08:40 EST by Martin Mucha
Modified: 2016-02-10 14:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 06:57:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑3.6.z?
rule-engine: planning_ack?
danken: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 1287665 None None None Never
oVirt gerrit 49122 ovirt-engine-3.6 MERGED core,restapi: fixed potential NPE and removed duplicity Never

  None (edit)
Description Martin Mucha 2015-12-02 08:40:51 EST
Description of problem:
NPE can occur in VdsNetworkInterface when 'isPartOfBond' is called on interface which is not part of bond.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-12-02 10:13:01 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 2 Oved Ourfali 2015-12-03 00:57:14 EST
whiteboard?
Comment 3 Yaniv Kaul 2015-12-04 10:17:57 EST
severity?
Comment 6 Red Hat Bugzilla Rules Engine 2015-12-08 02:51:57 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 7 Red Hat Bugzilla Rules Engine 2015-12-08 02:51:57 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 8 Red Hat Bugzilla Rules Engine 2015-12-08 02:51:57 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Michael Burman 2015-12-13 04:24:11 EST
Hi Martin,

Please provide the exact steps to verify this report.
Comment 10 Martin Mucha 2015-12-14 03:41:47 EST
Hi, I don't know whether this could cause failure for customer ~ it may have been catch by some validation I don't know. I found it just by reading code. 

marking as code change.
Comment 11 Meni Yakove 2015-12-14 04:29:52 EST
Martin, please close it as CURRENTRELEASE or NEXTRELEASE
Comment 12 Sandro Bonazzola 2015-12-22 07:45:08 EST
Hi, this bug is referenced in git log for ovirt-engine-3.6.2 tag but the target milestone is 3.6.1, can you please check?
Comment 13 Dan Kenigsberg 2015-12-31 03:22:40 EST
Sorry, but the only output line of

 git log --grep 1287665 ovirt/ovirt-engine-3.6.2 

is commit ff6a32fc, which has been properly backported to to 3.6.1 as well.
Comment 14 Sandro Bonazzola 2016-01-13 04:29:21 EST
(In reply to Dan Kenigsberg from comment #13)
> Sorry, but the only output line of
> 
>  git log --grep 1287665 ovirt/ovirt-engine-3.6.2 
> 
> is commit ff6a32fc, which has been properly backported to to 3.6.1 as well.

git log --grep 1287665 ovirt-engine-3.6.1.3
If it has been backported to 3.6.1, it has never been released.

and I don't even see it in 3.6.1:
git log --grep 1287665 origin/ovirt-engine-3.6.1
Comment 15 Dan Kenigsberg 2016-01-13 06:36:45 EST
The patch is missing BZ, and the BZ is missing acks - you're right, the process was not followed properly. But the patch is properly placed in master, 3.6, and 3.6.1:

https://gerrit.ovirt.org/#/q/Ia913e0f2069fa63b07be3f640600c1867406eda7
Comment 16 Sandro Bonazzola 2016-01-13 11:56:59 EST
(In reply to Dan Kenigsberg from comment #15)
> The patch is missing BZ, and the BZ is missing acks - you're right, the
> process was not followed properly. But the patch is properly placed in
> master, 3.6, and 3.6.1:
> 
> https://gerrit.ovirt.org/#/q/Ia913e0f2069fa63b07be3f640600c1867406eda7

Ok, that explain all. Thanks.

Note You need to log in before you can comment on or make changes to this bug.