Bug 128768 - --ro option in mount root fs ignored
Summary: --ro option in mount root fs ignored
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-29 10:28 UTC by Alexey
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-08-02 22:36:47 UTC


Attachments (Terms of Use)

Description Alexey 2004-07-29 10:28:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.23  [en]

Description of problem:
when mounting rootfs in linuxrc command is 
mount -o $rootopts --ro -t $rootfs $rootdev /sysroot" >> $RCFILE
--ro option ignored by mount and root mounted in rw mode
-o ro in place of --ro - is solution
version util-linux is 2.12-18

Version-Release number of selected component (if applicable):
mkinitrd-3.5.22-1

How reproducible:
Always

Steps to Reproduce:
1. plase line like /dev/md1 / ext3 rw 1 1 in /etc/fstab
2. run mkinitrd, lilo...etc
3. beboot
    

Actual Results:  at startup system drops you in resqueue console 
whist message that rootfs can't be check becouse it is already 
mounted

Additional info:

Comment 1 Jeremy Katz 2004-08-02 22:36:47 UTC
This is because you're explicitly saying that / should be mounted rw
in your fstab and mkinitrd will listen to this.  You really want
'defaults' there, not 'rw'.


Note You need to log in before you can comment on or make changes to this bug.