Bug 1287791 - cannot obtain ipv6 routes after automated tests
cannot obtain ipv6 routes after automated tests
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Rashid Khan
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 11:50 EST by Vladimir Benes
Modified: 2015-12-11 08:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-11 08:13:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2015-12-02 11:50:35 EST
Description of problem:
not sure what's causing this but I cannot get ipv6 dhcp routes after some tests.

I should have both 2001* and 2620 ipv6 addresses but I have just 2001 (sometimes)

[root@qe-dell-ovs5-vm-44 ~]# ip -6 r
2001:db8:1::/64 dev eth0  proto ra  metric 100 
fe80::/64 dev eth0  proto kernel  metric 256 
default via fe80::be30:5bff:fef3:b566 dev eth0  proto static  metric 100 

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:02:2c:e1:54 brd ff:ff:ff:ff:ff:ff
    inet 10.16.134.50/23 brd 10.16.135.255 scope global dynamic eth0
       valid_lft 43080sec preferred_lft 43080sec
    inet6 2620:52:0:1086:c533:bb2e:86d8:5b3/64 scope global noprefixroute dynamic 
       valid_lft 2591970sec preferred_lft 604770sec
    inet6 2001:db8:1:0:352e:cfe7:aa9:4a5b/64 scope global noprefixroute dynamic 
       valid_lft 86370sec preferred_lft 14370sec
    inet6 fe80::b272:dcc8:955d:8750/64 scope link 
       valid_lft forever preferred_lft forever

seems I can fix it with:
[root@qe-dell-ovs5-vm-44 ~]# systemctl restart NetworkManager
[root@qe-dell-ovs5-vm-44 ~]# ip -6 r
2001:db8:1::/64 dev eth0  proto ra  metric 100 
fe80::/64 dev eth0  proto kernel  metric 256 
default via fe80::be30:5bff:fef3:b566 dev eth0  proto static  metric 100 

and in a while
[root@qe-dell-ovs5-vm-44 ~]# ip -6 r
2001:db8:1::/64 dev eth0  proto ra  metric 100 
2620:52:0:1086::/64 dev eth0  proto ra  metric 100 
fe80::/64 dev eth0  proto kernel  metric 256 
fe80:52:0:1086::fc dev eth0  proto static  metric 100 
default via fe80:52:0:1086::fc dev eth0  proto static  metric 100 

I was waiting a lot before too, so timing issue is not possible

Version-Release number of selected component (if applicable):
master from 11/30/2015

How reproducible:
randomly
Comment 1 Vladimir Benes 2015-12-03 06:07:34 EST
this seems to be connected to race between two radvd servers, so very likely a setup issue not NM. invetigating now.
Comment 2 Vladimir Benes 2015-12-11 08:13:07 EST
this was caused by yet another radvd server and thus bad routing from time to time

Note You need to log in before you can comment on or make changes to this bug.