Bug 1287806 - Request: qt5-version of libqxt
Request: qt5-version of libqxt
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libqxt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabio Alessandro Locati
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 12:53 EST by Ali Akcaagac
Modified: 2015-12-07 13:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 13:54:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali Akcaagac 2015-12-02 12:53:46 EST
I would like to request a qt5-version of libqxt.

Reasons:

lxqt 0.10, as part of one of the desktop groups, depend on qt5. So far this is quite good and works so far. qterminal has been chosen to be the default (for the time being) terminal emulator. Unfortunately qterminal, which comes bundled with fedora, still depends on qt4 because of the libqxt dependeny - as I understand - that only exists for qt4. Therefore qterminal, as dependeny, pulls in the entire qt4 library tail for just one terminal emulator. A needless requirement since qterminal (as I understand) can be compiled and linked using qt5 (which also affects theming and so on). Unfortunately this requires a libqxt version that works with qt5.

The Maintainers of qterminal have described the needed requirements on the following report:

https://bugzilla.redhat.com/show_bug.cgi?id=1287450
Comment 1 Ali Akcaagac 2015-12-07 13:54:51 EST
Fixed in the qterminal package already.

Note You need to log in before you can comment on or make changes to this bug.