Bug 1287827 - [RFE] replicators: when no events exists for the replicators the timeline button becomes greyed out
[RFE] replicators: when no events exists for the replicators the timeline but...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity high
: GA
: cfme-future
Assigned To: John Hardy
Dafna Ron
ui
: FutureFeature
Depends On:
Blocks: 1290222
  Show dependency treegraph
 
Reported: 2015-12-02 13:47 EST by Dafna Ron
Modified: 2017-08-28 11:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1290222 (view as bug list)
Environment:
Last Closed: 2017-08-28 11:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screenshot (1.95 MB, application/x-gzip)
2015-12-02 13:47 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2015-12-02 13:47:03 EST
Created attachment 1101594 [details]
logs and screenshot

Description of problem:

This only happens to replicators and not to pods/containers. 
However, I think it's wrong behaviour and that the button should always be available and if no events exists simply say that in the query. 
 
Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. create a replicator and delete the event from db or... add an existing openshift provider with a very old replicator running which no longer has any events on it
2. navigate to containers -> replicator
3. select the relicator -> monitoring -> timeline

Actual results:

timeline is greyed out

Expected results:

timeline should not be greyed out but we should be able to select it and get a message that no events exists for the replicator

Additional info: screen shot and logs attached

http://pastebin.test.redhat.com/332347
Comment 1 Harpreet Kataria 2015-12-02 15:06:21 EST
Dafna,

That is the correct behavior across UI to disable/grey out Timelines button when there are no events available for an object.
I think this is not an issue, so the BZ should be closed.

Thanks,
~Harpreet
Comment 2 Dafna Ron 2015-12-03 04:30:41 EST
honestly I think that current behaviour looks like a bug which is why I opened it :) I think it's much better to allow selection and report that no events exist for the object. 
I understand that this is the current agreed behaviour but speaking from a user prospective I think it should be changed and do not think this bug should be closed. 
Having said that, I have no objections to change this to an RFE so it could be discussed in future.
Comment 3 Harpreet Kataria 2015-12-04 10:30:02 EST
Dafna,

I think this should be changed to RFE, since that's the existing behavior for all Timelines buttons across the UI.

Thanks,
~Harpreet
Comment 4 Dafna Ron 2015-12-07 05:57:24 EST
(In reply to Harpreet Kataria from comment #3)
> Dafna,
> 
> I think this should be changed to RFE, since that's the existing behavior
> for all Timelines buttons across the UI.
> 
> Thanks,
> ~Harpreet

Agreed.
We do not have an RFE component so I am not sure how to do that.
Comment 6 Federico Simoncelli 2016-07-13 03:30:35 EDT
According to comment 1 this is not related to containers.
Comment 8 Chris Pelland 2017-08-28 11:10:17 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.