Bug 1287856 - Containers: 'Unexpected error encountered' when selecting "back" arrow -> all containers
Containers: 'Unexpected error encountered' when selecting "back" arrow -> all...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
unspecified Severity high
: GA
: 5.5.3
Assigned To: Dan Clarizio
Dave Johnson
: ZStream
Depends On: 1285837
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 15:43 EST by John Prause
Modified: 2016-02-25 13:04 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285837
Environment:
Last Closed: 2016-02-25 13:04:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Prause 2015-12-02 15:43:16 EST
+++ This bug was initially created as a clone of Bug #1285837 +++

Description of problem:

occurs when selecting "back" arrow -> all containers

Version-Release number of selected component (if applicable):

cfme-5.5.0.12-rc2.1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to containers -> containers
2. select a container
3. select back arrow -> all containers

Actual results:

Unexpected error encountered 

Expected results:

We should go back to view all containers

Additional info:



Unexpected error encountered

Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine. Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
      Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
      Please contact your administrator for assistance.


Error text:

undefined method `name' for nil:NilClass [container/x_history]

--- Additional comment from Erez Freiberger on 2015-11-29 07:42:40 EST ---

I can not reproduce the bug. tested on upstream and on 5.5.0.12
Could you attach evm.log ?

--- Additional comment from Dafna Ron on 2015-11-30 05:30:31 EST ---

My vm rebooted and I was unable to reproduce again.
I think it has to do with us saving the history of screens that had an error.
Since I only selected one object which had an exception, once I pressed the back button I got that screen.

Perhaps this bug needs to change to "we are saving history of exception screens"?

--- Additional comment from Federico Simoncelli on 2015-11-30 06:10:08 EST ---

(In reply to Dafna Ron from comment #2)
> My vm rebooted and I was unable to reproduce again.
> I think it has to do with us saving the history of screens that had an error.
> Since I only selected one object which had an exception, once I pressed the
> back button I got that screen.
> 
> Perhaps this bug needs to change to "we are saving history of exception
> screens"?

Try to reproduce, if that's the case this is a generic bug and it should be reassigned to Dan (remove container from the whiteboard as well).
Comment 2 Federico Simoncelli 2016-02-05 09:00:27 EST
Based on bug 1285837 comment 4 I think this is not material for 5.5.3 or anyway it's not in the "container" scope.

Let's see what happens on bug 1285837 and we'll either close or move this.

Note You need to log in before you can comment on or make changes to this bug.