Bug 1287927 - Extra components are not displayed on multi component bugs.
Extra components are not displayed on multi component bugs.
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 21:21 EST by Rony Gong
Modified: 2015-12-15 21:14 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.4.10045.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 21:14:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2015-12-02 21:21:53 EST
Description of problem:
It only save one component when creating bug with multi components

Version-Release number of selected component (if applicable):
4.4.10045-2

How reproducible:
100%

Steps to Reproduce:
1.Create a bug against 'JBoss Enterprise Application Platform 6' which allow multi components, select components: distribution, build
2.Input some other field for this bug, save this bug.
3.

Actual results:
It only save one component: distribution

Expected results:
It should save all selected components 

Additional info:
Comment 1 Matt Tyson 2015-12-03 00:23:42 EST
The problem was that we were only showing the first component.

Extra components we not being queried or selected.

Since we need the component object, not just the component name. I've added a new 'all_component_objs' method to make this work.
Comment 2 Rony Gong 2015-12-03 02:46:36 EST
Tested on 
QA environment(bzperfweb01.app.qa) with version(4.4.10045-3, DB: psql)
Result: Pass
Comment 3 Matt Tyson 2015-12-15 21:14:18 EST
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.