Bug 128795 - scripts/services/sendmail misses max load average
scripts/services/sendmail misses max load average
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-29 13:05 EDT by Gilbert E. Detillieux
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 14:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix incorrect variable reference in scripts/services/sendmail (396 bytes, patch)
2004-07-29 13:07 EDT, Gilbert E. Detillieux
no flags Details | Diff

  None (edit)
Description Gilbert E. Detillieux 2004-07-29 13:05:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030113

Description of problem:
LogWatch reports don't give the correct value for "Max. Load Avg
reached" in the sendmail section of the report, due to an error in
/etc/log.d/scripts/services/sendmail, where an incorrect variable is used.

Version-Release number of selected component (if applicable):
logwatch-5.1-3

How reproducible:
Always

Steps to Reproduce:
1. Allow load average to get high enough for sendmail to log that.
2. Let logwatch run via cron the next day.
3. Read report, see incorrect "Max. Load Avg reached" value (likely 0).
    

Actual Results:  Value reported is incorrect, and likely always 0.

Expected Results:  The maximum value from the sendmail log entries
should be reported.

Additional info:

Patch to follow...
Comment 1 Gilbert E. Detillieux 2004-07-29 13:07:35 EDT
Created attachment 102290 [details]
patch to fix incorrect variable reference in scripts/services/sendmail
Comment 2 Elliot Lee 2004-08-23 14:51:50 EDT
This fix is included in logwatch 5.2.2. Thanks!

Note You need to log in before you can comment on or make changes to this bug.