Bug 1287970 - Random delay on shutdown/reboot
Random delay on shutdown/reboot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 02:57 EST by Saurav Sg
Modified: 2016-01-14 04:38 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 08:54:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shutdown log as requested in comment #3 (1014.12 KB, text/plain)
2015-12-12 06:15 EST, Saurav Sg
no flags Details

  None (edit)
Description Saurav Sg 2015-12-03 02:57:34 EST
Description of problem:
There is a sometimes a delay of several seconds when attempting a shutdown/reboot from GNOME (3.18). The occurrence is totally random, the Plymouth splash screen sometimes appears while at other times the screen goes blank with just a text-mode cursor visible, and no messages appear. No key presses respond, including Esc (for Plymouth messages) and Ctrl+Alt+Fx (for virtual terminals). There are no messages of "stop job is running" as was the case for a bug earlier. A "watchdog did not stop" message has appeared on a few occasions, but it has also appeared on some occasions when the delay did not occur. A hard reset is not required, however; the system shuts down (apparently properly) after the inexplicable delay. I do not know which component is causing this. My kernel version is 4.2.6-301 as of this writing. I am facing the issue since a few days ago; I encountered no such problem earlier since the release of Fedora 23. There has been no change to the system that I am aware of, except the regular software updates, and no updates from testing repositories.

Version-Release number of selected component (if applicable):


How reproducible:
Random
Comment 1 Kevin Fenzi 2015-12-04 21:34:42 EST
Moving over to systemd folks for comment...
Comment 2 Saurav Sg 2015-12-05 04:06:29 EST
If any messages appear at all (e.g., "watchdog did not stop" or "going down for reboot" or "rebooting"), they always appear after the delay. That is, if I see any messages, I know that the delay is over and the system will power down or reboot now.
Comment 3 Michal Sekletar 2015-12-05 05:02:13 EST
Please follow instructions at [1] (paragraph "Shutdown Completes Eventually") and attach obtained shutdown log.

[1] http://freedesktop.org/wiki/Software/systemd/Debugging/
Comment 4 Saurav Sg 2015-12-05 05:19:56 EST
(In reply to Michal Sekletar from comment #3)
> Please follow instructions at [1] (paragraph "Shutdown Completes
> Eventually") and attach obtained shutdown log.
> 
> [1] http://freedesktop.org/wiki/Software/systemd/Debugging/

I have set my system up according to the instructions, but because the problem is random and infrequent, I will have to wait until it occurs again. Should I attach only the log obtained after a delayed shutdown or the one obtained in any case?
Comment 5 Lukáš Nykrýn 2015-12-07 06:17:25 EST
Just for the delayed shutdown.
Comment 6 Saurav Sg 2015-12-12 06:15 EST
Created attachment 1105005 [details]
Shutdown log as requested in comment #3

Attached the shutdown log for a delayed reboot.
Comment 7 Saurav Sg 2015-12-13 09:02:41 EST
I have got another shutdown log from a delayed shutdown (power down). Please let me know if it is required.
Comment 8 Jan Synacek 2016-01-11 03:34:45 EST
Please, also specify the systemd version you are using.

How frequently does this problem occur? I can't reproduce this, but I could backport some watchdog patches and provide you with the packages. Would you be willing to test those?
Comment 9 Jan Synacek 2016-01-11 04:33:49 EST
One more thing you can do.

1) Enable debug shell (systemctl enable debug-shell.service).
2) When the shutdown hangs, switch to tty9 and execute "systemctl list-jobs" and attach the output to this bugzilla.
3) Disable debug shell.
Comment 10 Saurav Sg 2016-01-12 04:57:18 EST
(In reply to Jan Synacek from comment #8)
> Please, also specify the systemd version you are using.

Unfortunately, I did not note the version number. I think I have had two regular upgrades to systemd since then, which were 222-11 and 222-12, so the version which was installed when I reported the bug was probably 222-10.

> How frequently does this problem occur? I can't reproduce this, but I could
> backport some watchdog patches and provide you with the packages. Would you
> be willing to test those?

The problem has always occurred randomly, sometimes twice in a row, sometimes not even once in several days. However, ever since the upgrade to 222-11, I have not experienced the problem, but I can't know if it is gone for good. I don't know what the proper procedure is in such cases; perhaps the bug could be closed and later reopened if the problem occurs again?
Comment 11 Jan Synacek 2016-01-13 08:54:50 EST
Ok, I'm closing this bug now. If it happens again, please also attach the output of "systemctl list-jobs" (described in comment 9).

Note You need to log in before you can comment on or make changes to this bug.