Bug 1287971 - anaconda 13.21.229 exception report - TypeError: argument 1 must be Entity, not None
anaconda 13.21.229 exception report - TypeError: argument 1 must be Entity, n...
Status: CLOSED DUPLICATE of bug 1286537
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.8
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 03:04 EST by xhe@redhat.com
Modified: 2016-05-09 21:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 04:29:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb-yjbgDo (708.13 KB, text/plain)
2015-12-03 04:57 EST, xhe@redhat.com
no flags Details
anaconda.log (28.76 KB, text/plain)
2015-12-03 04:58 EST, xhe@redhat.com
no flags Details
program.log (61.37 KB, text/plain)
2015-12-03 04:58 EST, xhe@redhat.com
no flags Details
storage.log (219.42 KB, text/plain)
2015-12-03 04:59 EST, xhe@redhat.com
no flags Details

  None (edit)
Description xhe@redhat.com 2015-12-03 03:04:32 EST
Description of problem:
I tied to install rhel6.7 on remote LUN, but error occurs when installation close to finish.

Version-Release number of selected component (if applicable):
anaconda 13.21.229
kernel 2.6.32-504.38.1.el6.x86_64
Building RHEL-6.8-20151202.n.0

How reproducible:
not sure

Steps to Reproduce:
1. Install the whole RHEL6.7 on the 30G Lun (on NetAPP2240)
2. Error occurs when the installation close to finish

Actual results:

anaconda 13.21.229 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/users.py", line 245, in setUserPassword
    self.admin.setpassUser(user, cryptPassword(password, algo=algo), True)
  File "/usr/lib/anaconda/users.py", line 253, in setRootPassword
    return self.setUserPassword("root", password, isCrypted, lock, algo)
  File "/usr/lib/anaconda/instdata.py", line 181, in write
    algo=self.getPassAlgo())
  File "/usr/lib/anaconda/backend.py", line 246, in writeConfiguration
    anaconda.id.write()
  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1370, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1391, in handleRenderCallback
    self.currentWindow.renderCallback()
TypeError: argument 1 must be Entity, not None

Local variables in innermost frame:
username: root
isCrypted: False
lock: False
self: <users.Users instance at 0x7ff3af7fd878>
user: None
algo: sha512


Expected results:
No error occurs

Additional info:
Comment 2 xhe@redhat.com 2015-12-03 04:57 EST
Created attachment 1101728 [details]
anaconda-tb-yjbgDo
Comment 3 xhe@redhat.com 2015-12-03 04:58 EST
Created attachment 1101729 [details]
anaconda.log
Comment 4 xhe@redhat.com 2015-12-03 04:58 EST
Created attachment 1101730 [details]
program.log
Comment 5 xhe@redhat.com 2015-12-03 04:59 EST
Created attachment 1101731 [details]
storage.log
Comment 6 Samantha N. Bueno 2015-12-04 08:08:04 EST
Try using a more recent nightly e.g. from 20151203 or later and let me know if this still occurs. The nightly you're using was built using a version of anaconda that's over a year old, due to some mistake on rel-eng's part.
Comment 7 Marian Ganisin 2015-12-07 04:29:28 EST
This is duplicate of Bug 1286537 and actually this is rather RCM issue as the anaconda version does not seem to be appropriate for RHEL-6.8. FYI there isn't working nightly compose so far.

*** This bug has been marked as a duplicate of bug 1286537 ***
Comment 8 xhe@redhat.com 2016-05-09 21:53:26 EDT
it cannot be reproduced on the later version.

Note You need to log in before you can comment on or make changes to this bug.