Bug 1288011 - kdevelop locks up using 100% CPU
kdevelop locks up using 100% CPU
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 05:21 EST by Dr I JOrmshaw
Modified: 2016-01-29 11:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 11:49:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Archive of project directory (8.51 KB, application/x-bzip)
2015-12-03 05:21 EST, Dr I JOrmshaw
no flags Details

  None (edit)
Description Dr I JOrmshaw 2015-12-03 05:21:18 EST
Created attachment 1101739 [details]
Archive of project directory

Description of problem:

kdevelop repeatedly locks up when it does this the kdevelop process
is using 100% cpu

Version-Release number of selected component (if applicable):

kdevelop-9:4.7.2-1.fc23.x86_64

How reproducible:

Always within a minuet or two of editing the source file

Steps to Reproduce:
1.  untar the attachment in ${HOME}/projects
2.  in kdevelop import the project ftw from ${HOME}/projects
3.  in kdevelop open main.cpp
4.  make trivial to the file main.cpp
    e.g. insert and delete blank lines
    change the 32 in line 52 to another number
5.  build and run ftw
6.  repeat steps 4 and 5

Actual results:

kdevelop locks up

Expected results:

kdevelop should not lock up

Additional info:
Comment 1 Dr I JOrmshaw 2015-12-10 09:19:52 EST
This has been reproduced on 2 separate Fedora 23 systems and on Fedora 22, but not on Fedora 21.
Comment 2 Ngo Than 2016-01-26 06:18:37 EST
i can reproduce this issue. Is it the same kdevelop version on f21?
Comment 3 Dr I JOrmshaw 2016-01-26 07:34:49 EST
I've just booted up to a Fedora 21 live CD and installed kdevelop.  I get the same version as I have on Fedora 23
Comment 4 Ngo Than 2016-01-27 08:13:17 EST
please try new kdevelop-4.7.3 and give me feedbacks. This issue should be fixed in this new version

 http://koji.fedoraproject.org/koji/buildinfo?buildID=713819
Comment 5 Dr I JOrmshaw 2016-01-27 10:22:44 EST
Where should I get that from as it doesn't appear to be in the update-testing repo?
Comment 6 Ngo Than 2016-01-29 03:56:35 EST
it should be available in update-testing. 

https://bodhi.fedoraproject.org/updates/FEDORA-2016-015ca8d3c3
Comment 7 Dr I JOrmshaw 2016-01-29 05:17:41 EST
The fix has now appeared in update-testing.

From preliminary quick testing, I cannot reproduce the error.

Note You need to log in before you can comment on or make changes to this bug.