Bug 1288034 - Chapter 6 regarding virt-who contains deprecated configuration instructions
Chapter 6 regarding virt-who contains deprecated configuration instructions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Virtual Instances Guide (Show other bugs)
6.1.4
Unspecified Unspecified
high Severity high (vote)
: GA
: 6.2
Assigned To: Russell Dickenson
Stephen Wadeley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 05:55 EST by Ture Karlsson
Modified: 2016-06-16 00:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 00:21:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ture Karlsson 2015-12-03 05:55:00 EST
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/ 

Section Number and Name:
Chapter 6. Managing Hypervisors and Virtual Guest Subscriptions

Describe the issue:
This chapter contains some information that is not correct (confirmed with virt-who 0.14):
6.2.1 - Prerequisites
"The system running virt-who is registered already to the Satellite server(virt-who will use the host credentials)."

This is not correct anymore. virt-who can be run on a system that isn't registered to the Satellite. It can also run on the Satellite itself even if it is not self-registered.

6.2.3 - virt-who Configuration File Location
"The virt-who configuration is stored in the following configuration files: /etc/sysconfig/virt-who (default)"

The configuration should be done in configuration files in /etc/virt-who.d/ instead of /etc/sysconfig/virt-who (it even says so in that file).

6.4, 6.5, 6.6 are using /etc/sysconfig/virt-who for configuration.

Suggestions for improvement: 
The prerequisites should clearly state that virt-who can run on any system regardless if it is registered to the Satellite or if it is virtual/physical.

There should be configuration examples using files in /etc/virt-who.d/ instead of /etc/sysconfig/virt-who.

I think it should be some information about running virt-who on the Satellite itself (self-registered or not, physical or virtual) since that is now possible.

Additional information:
I've successfully run virt-who 0.14 on a physical Satellite 6.1.4 that was not self-registered against vCenter and RHEV with the following configurations:

# cat /etc/virt-who.d/esx.conf
[esx]
type=esx
server=<vcenter fqdn> 
username=<domain>\<username>
password=<password>
owner=<organization>
env=Library
hypervisor_id=hostname
rhsm_hostname=<satellite fqdn>
rhsm_prefix=/rhsm
rhsm_username=<satellite username>
rhsm_password=<satellite password>

# cat /etc/virt-who.d/rhevm.conf
[rhevm]
type=rhevm
server=<rhev fqdn>:443
username=<username>@internal
password=<password>
owner=<organization>
env=Library
hypervisor_id=hostname
rhsm_hostname=<satellite fqdn>
rhsm_prefix=/rhsm
rhsm_username=<satellite username>
rhsm_password=<satellite password>
Comment 3 Andrew Dahms 2016-05-02 20:40:42 EDT
Assigning to Russell for review.
Comment 4 Russell Dickenson 2016-05-04 00:55:17 EDT
Ture,

I believe the requirements specified in this BZ ticket will be met by the Satellite 6.2 "Virtual Instances Guide", which is available for the Beta at [1].

Please review the guide and confirm whether or not it delivers what you had requested.


[1] https://access.stage.redhat.com/documentation/en/red-hat-satellite/version-6.2-beta/virtual-instances-guide/
Comment 5 Ture Karlsson 2016-05-04 04:29:22 EDT
Hi Russell,

I miss the part regarding how to configure virt-who to report to a Satellite that is not self registered. Chapter 5.3 through 5.5 contains good examples of configurations for esx, hyper-v and rhevm but all of these examples assumes that the Satellite is self registered. The following lines from the config example in this BZ would be needed if the Satellite is not self registered (if I'm not mistaken):

rhsm_hostname=<satellite fqdn>
rhsm_prefix=/rhsm
rhsm_username=<satellite username>
rhsm_password=<satellite password>

# or with encrypted password
rhsm_encrypted_password=<encrypted satellite password>
Comment 13 Andrew Dahms 2016-06-16 00:21:27 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.