Bug 1288085 - glusterd related core observed while probing a node which is already in cluster.
glusterd related core observed while probing a node which is already in cluster.
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gaurav Kumar Garg
storage-qa-internal@redhat.com
glusterd
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 08:08 EST by Shashank Raj
Modified: 2016-11-07 22:52 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 13:04:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shashank Raj 2015-12-03 08:08:14 EST
Description of problem:

glusterd related core observed while probing a node which is already in cluster.

Version-Release number of selected component (if applicable):

glusterfs-3.7.5-8

How reproducible:


Steps to Reproduce:
1.While running automated cases related to snapshots observed core related to glusterd.
2.This happened while probing a node which is already a part of the cluster.

Actual results:

glusterd related core observed

Expected results:


Additional info:
Comment 2 Shashank Raj 2015-12-03 08:19:53 EST
sos reports are at http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1288085
Comment 3 Gaurav Kumar Garg 2015-12-07 03:52:02 EST
Hi shashank,

core file is missing from the sos report. could you check it again and attach core file somewhere so can we can analyse this issue. we need core file to analyse this issue.
Comment 4 Shashank Raj 2015-12-07 04:25:34 EST
core file is placed at http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1288085/core/core.4750
Comment 5 Gaurav Kumar Garg 2015-12-09 02:09:43 EST
Hi Shashank,

Its very rare to reproduce this issue. glusterd crashed because at the time of sending response to CLI some application have corrupted dictionary data. by looking into backtrace using gdb we didn't found out much information regarding this which application have corrupted dictionary and freed its one of the member which is trying to free again.
Comment 6 Atin Mukherjee 2015-12-10 23:15:30 EST
Lowering both priority and severity as the crash is not reproducible.
Comment 7 Atin Mukherjee 2016-02-11 13:04:29 EST
Shashank,

Since this bug is not reproducible and we haven't heard any such core in recent times closing this bug. Feel free to reopen if you hit it again.

Note You need to log in before you can comment on or make changes to this bug.