Bug 1288097 - Command `nova floating-ip-create` fails when deploying with ospd
Command `nova floating-ip-create` fails when deploying with ospd
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ga
: 8.0 (Liberty)
Assigned To: chris alfonso
Daniel Mellado
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 09:02 EST by Daniel Mellado
Modified: 2016-01-31 21:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 06:47:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1370448 None None None Never

  None (edit)
Description Daniel Mellado 2015-12-03 09:02:08 EST
Description of problem:

Tempest tests requiring floating_ip pool are failing, this seems to be an identical case as the issue in LP.

A value for the defualt nova floating pool should be added in DEFAULT/default_floating_pool

How reproducible:

Command `nova floating-ip-create` fails with ERROR: FloatingIpPoolNotFound: Floating ip pool not found. (HTTP 404) (Request-ID: req-52256308-b9ac-457e-8b5c-e1df5dcc31cd)


Actual results:

ERROR: FloatingIpPoolNotFound: Floating ip pool not found.

Expected results:

For the FIP to be created

Additional info:

https://review.openstack.org/#/c/156189/

Workaround

Run floating-ip-create command with floating IP pool specified, for instance:

nova floating-ip-create novapool
Comment 2 Alexander Chuzhoy 2015-12-07 12:09:06 EST
Running "nova floating-ip-create  [<floating-ip-pool>]" manually works for me on 8.0.
Comment 3 Jaromir Coufal 2015-12-07 13:34:09 EST
Dan, we could not reproduce this in 8.0, could you please verify whether you are still hitting the bug with the latest puddle?
Comment 7 Jaromir Coufal 2016-01-27 06:47:06 EST
Thanks. Closing please re-open if the issue reappears.

Note You need to log in before you can comment on or make changes to this bug.