Bug 1288201 - virt-builder writes temporary files to /tmp
virt-builder writes temporary files to /tmp
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pino Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 14:40 EST by Richard W.M. Jones
Modified: 2015-12-04 05:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 05:09:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2015-12-03 14:40:03 EST
Description of problem:

Although virt-builder obeys $TMPDIR, by default (if TMPDIR is not
set) it will try to write temporary files to /tmp.  Since the
temporary image files are very large, it ought to write them
to /var/tmp.  Otherwise people suffering from tmp-on-tmpfs
brokenness will have problems.

(Reported by adamw on IRC).

Version-Release number of selected component (if applicable):

libguestfs 1.30 and above.

How reproducible:

100%

Steps to Reproduce:
1. With restricted space in /tmp run virt-builder.
Comment 1 Pino Toscano 2015-12-04 05:09:34 EST
Fixed with
https://github.com/libguestfs/libguestfs/commit/a090a48f44e8d0c6e3410855b087cc936b1ee1ad
which is libguestfs >= 1.31.29.

Note You need to log in before you can comment on or make changes to this bug.