Bug 1288258 - Touchpad/Clickpad not working at all
Touchpad/Clickpad not working at all
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 18:58 EST by truekdc
Modified: 2016-01-13 00:35 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 00:35:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod (15.16 KB, text/plain)
2015-12-07 07:29 EST, truekdc
no flags Details
synclient -l (12.39 KB, application/vnd.oasis.opendocument.text)
2015-12-07 07:35 EST, truekdc
no flags Details
evemu-record (13.37 KB, application/vnd.oasis.opendocument.text)
2015-12-07 07:37 EST, truekdc
no flags Details
xinput list-props for touchpad (11.97 KB, application/vnd.oasis.opendocument.text)
2015-12-07 07:41 EST, truekdc
no flags Details
dmesg (57.33 KB, text/plain)
2015-12-08 06:38 EST, truekdc
no flags Details
hid-recorder (617 bytes, text/plain)
2015-12-08 10:02 EST, truekdc
no flags Details

  None (edit)
Description truekdc 2015-12-03 18:58:01 EST
Description of problem:
Xinput recognizes my touchpad (clickpad) but does not respond to its use in any way.

Version-Release number of selected component (if applicable):


How reproducible: Constant, ever since install.


Steps to Reproduce:
1.Start up machine.
2.Restart machine.
3.

Actual results: Touchpad does not function.


Expected results: Touchpad shuuld function.


Additional info:
Dell Inspiron 3452

Memory: 1.9GB

Processor: Intel Celeron CPU N3050 @ 1.60Ghz x2

OS Type: 64-bit

Graphics: Intel HD Graphics (Cherryview)

GNOME: Version 3.18.1

Disk: 27.5 GB

sudo journalctl | grep -i "SynPS/2" -->  http://pastebin.com/fYDTnNA9

lsmod --> http://pastebin.com/CBxJxYc8

Synclient -l   --> http://pastebin.com/n7tyfsBe

Added "blacklist i2c-hid" to /etc/modprobe.d/blacklist.conf
Comment 1 truekdc 2015-12-03 19:06:18 EST
xinput version 1.6.2
XI version on server: 2.3

Linux 4.2.6-301.fc23.x86_64
Comment 2 Mamoru TASAKA 2015-12-03 20:42:47 EST
Once switching to xorg-x11-drv-synaptics ??
Comment 3 truekdc 2015-12-04 07:12:41 EST
I have reinstalled org-x11-drv-synaptics using:

sudo dnf reinstall xorg-x11-drv-synaptics


But I don't know that I ever switched to xorg-x11-drv-synaptics, the touchpad has not worked since installing the OS and I have not done anything that I believe would have switched to xorg-x11-drv-synaptics from something else...
Comment 4 truekdc 2015-12-05 16:57:55 EST
(In reply to Mamoru TASAKA from comment #2)
> Once switching to xorg-x11-drv-synaptics ??

I have reinstalled org-x11-drv-synaptics using:

sudo dnf reinstall xorg-x11-drv-synaptics


But I don't know that I ever switched to xorg-x11-drv-synaptics, the touchpad has not worked since installing the OS and I have not done anything that I believe would have switched to xorg-x11-drv-synaptics from something else...
Comment 5 Peter Hutterer 2015-12-06 20:10:33 EST
run evemu-record against the kernel device, do a short movement with a finger and attach the output here please, thanks.

if you run sudo libinput-debug-events, do you see events? If so, also attach xinput list-props "... device name ..."
Comment 6 truekdc 2015-12-06 21:35:09 EST
(In reply to Peter Hutterer from comment #5)
> run evemu-record against the kernel device, do a short movement with a
> finger and attach the output here please, thanks.
> 
> if you run sudo libinput-debug-events, do you see events? If so, also attach
> xinput list-props "... device name ..."

evemu-record  ---> http://pastebin.com/CiEBiYBU

After it reads "Waiting for events" nothing happens no matter what I try. I have to terminate the event by closing the terminal.



sudo libinput-debug-events similarly displays no response from touching the clickpad or clicking the clickable corners. Appears to recognize all movements from my external USB mouse and keyboard until I close the terminal, but nothing appears for the clickpad/touchpad.


I went ahead and included xinput list-props anyway in case it is useful in some way... 

 http://pastebin.com/Zdwd2rUC
Comment 7 Peter Hutterer 2015-12-07 00:34:48 EST
Please don't use pastebin for bugzilla files, use the "add an attachment" link above. pastebin is unreliable, if we need to revisit this bug somewhen down the track, the pastebin may have disappeared.
Comment 8 truekdc 2015-12-07 07:29 EST
Created attachment 1103210 [details]
lsmod

text from lsmod command in terminal
Comment 9 truekdc 2015-12-07 07:35 EST
Created attachment 1103211 [details]
synclient -l

output from the "synclient -l" command in terminal
Comment 10 truekdc 2015-12-07 07:37 EST
Created attachment 1103212 [details]
evemu-record

output from the "evemu-record" command in terminal
Comment 11 truekdc 2015-12-07 07:41 EST
Created attachment 1103213 [details]
xinput list-props for touchpad

output from the "xinput list-props" command for the touchpad in terminal
Comment 12 truekdc 2015-12-07 07:47:48 EST
(In reply to Peter Hutterer from comment #7)
> Please don't use pastebin for bugzilla files, use the "add an attachment"
> link above. pastebin is unreliable, if we need to revisit this bug somewhen
> down the track, the pastebin may have disappeared.

All of the outputs previously included through pastebin have been added to the bug report as attachments. Thank you for your help on this issue. Hopefully whatever this is helps improve the project.
Comment 13 Peter Hutterer 2015-12-07 22:15:03 EST
Next time please attach them as text files only. Anyway,

Inspiron14-3452 is what DMI says and the kernel doesn't detect the touchpad.
Comment 14 Peter Hutterer 2015-12-07 22:16:44 EST
oops, hit enter too early.

Reassigning to the kernel, the touchpad isn't detected and shows up as a relative mouse. Please attach your dmesg too (as a text file, not an odt file)
Comment 15 Benjamin Tissoires 2015-12-08 02:42:58 EST
(In reply to truekdc from comment #0)
> Description of problem:
> Xinput recognizes my touchpad (clickpad) but does not respond to its use in
> any way.
> ...
> Added "blacklist i2c-hid" to /etc/modprobe.d/blacklist.conf

Well, if you remove i2c-hid and you have a i2c-hid touchpad (which seems to become the rule with Dell laptops now), no wonders why you don't get a working touchpad.

Please remove this (why would you blacklist it in the first place?) and attach the dmesg of your kernel as requested by Peter.
Thanks
Comment 16 Benjamin Tissoires 2015-12-08 02:46:28 EST
my bad, thought these were plain text documents, sorry for the spam
Comment 17 truekdc 2015-12-08 06:38 EST
Created attachment 1103559 [details]
dmesg

output of the 'dmesg' command in terminal
Comment 18 truekdc 2015-12-08 06:42:19 EST
(In reply to Benjamin Tissoires from comment #15)
> (In reply to truekdc from comment #0)
> > Description of problem:
> > Xinput recognizes my touchpad (clickpad) but does not respond to its use in
> > any way.
> > ...
> > Added "blacklist i2c-hid" to /etc/modprobe.d/blacklist.conf
> 
> Well, if you remove i2c-hid and you have a i2c-hid touchpad (which seems to
> become the rule with Dell laptops now), no wonders why you don't get a
> working touchpad.
> 
> Please remove this (why would you blacklist it in the first place?) and
> attach the dmesg of your kernel as requested by Peter.
> Thanks

I added the blacklist before I initiated the bug report. I was kinda shooting in the dark trying whatever I could find online that had worked for other users.

I have removed the blacklist and restarted with no good effect. Both 
'evemu-record' and 'sudo libinput-debug-events' continue to produce no response.
Comment 19 Benjamin Tissoires 2015-12-08 08:07:00 EST
Thanks for attaching the logs. Your touchpad is indeed driven by hid-rmi and i2c_hid. Some Synaptics touchpads have a failover over PS/2, some don't. It is also possible that the touchpad needs a full power cycle to switch back to PS/2 when it has been configured as I2C once.

Anyway, the device through i2c-hid (which I strongly encourage to keep), is called "DLL06AC:00 06CB:78F1".
Could you attach a hid-recorder [1] of this touchpad while moving some fingers on it. We need to check what goes out of it and which part in the kernel prevents the events to be sent.

[1] http://bentiss.github.io/hid-replay-docs/
Comment 20 truekdc 2015-12-08 10:02 EST
Created attachment 1103636 [details]
hid-recorder

output from the hid-recorder command in terminal

No response from manipulating the touchpad.
Comment 21 truekdc 2015-12-08 10:03:34 EST
hid-recorder and selection the Dll06AC:00 06CB:78F1 had similar results. No response from touching, moving fingers or clicking on the touchpad.
Comment 22 truekdc 2015-12-08 13:19:50 EST
I am not sure if I had done a full power cycle before or just restarted... But I just did and nothing has changed.
Comment 23 truekdc 2015-12-18 17:27:05 EST
I had a dream that this problem somehow fixed itself... Unfortunately, it was just a dream.
Comment 24 Benjamin Tissoires 2016-01-04 10:03:54 EST
Apologies for the delay.

I am not sure what is going on with your touchpad. The device enumerates properly and is correctly set up, but there is no events coming out of it.

We had some problems in the i2c-designware controller that have been fixed in the rawhide kernel 4.4.0-rc6.

Would you mind getting a test at the latest rawhide kernel?
Comment 25 truekdc 2016-01-04 14:26:38 EST
Unfortunately since my machine was not functioning I went ahead and reinstalled a Microsoft OS with innate functionality. If I ever get around to testing your kernel for you I will update here...
Comment 26 Peter Hutterer 2016-01-13 00:35:34 EST
closing as deferred for now, please reopen when you get around to testing. Thanks

Note You need to log in before you can comment on or make changes to this bug.