Bug 1288346 - non-free is not hotpluggable
non-free is not hotpluggable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 23:45 EST by Richard Jasmin
Modified: 2015-12-05 00:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-05 00:11:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-12-03 23:45:07 EST
Description of problem:
reporting of upstream bugs require crippled installation of audacity.

non-free components should be, as-is with mplayer and vlc, some form of pluggable component or library.

THEN upstream bugs can properly be reported. non-free bugs can be sent to appropriate teams, ie: fraunhoffer staff or other staff.

misnomer:
ffmpeg itself and even mplayer for that matter are not non-free by default. The pluggable components of these apps ARE. DVD decryption, mp3 support, etc. etc. are  ADD-ONS. They DO NOT and SHOULD NOT ship by DEFAULT. These should be extra package installations.RPMFusion can more than handle the add-ons. They should NOT be forced to REWRITE the offending application to offer non-free functionality.

This is partly why the repos are jack screwed on mplayer-esque applications.Both mplayer and vlc are plugin based.Im pretty sure ffmpeg is as well.

If debian can get it right, we should be able to.

We should not be forced into reporting application bugs to non-free teams.They CANNOT fix application bugs.The problem is UPSTREAM in the application level code.And maintaining multiple versions is pointless waste.


Version-Release number of selected component (if applicable):
22

How reproducible:
on record

Steps to Reproduce:

CASE IN POINT(the real underlying BUG):
pavucontrol is open awaiting application status for loopback recording.
alsa is selected and pulse for recording from an oss source(another app)


Actual results:
AUDACITY CRASHES on record attempt.
[wait on input audio threshold is selected]

prior to this, oss application hogs the inputs and hardware 0,0 is not available to record from.

Expected results:
I should be able to see "record from monitor" in pavucontrol and be able to record a loopback audio file.

Additional info:
forced to use crippled audacity to report bug. freeworld from rpmfusion (with mp3, ffmpeg support) cannot report the bug, even though it is application level and NOT plugin related.
Comment 1 David Timms 2015-12-05 00:11:54 EST
I think these application level design change requests would be better passed to the Audacity developers. Shouting in bug reports does not help your case. If you have some code/patches to allow that please send them upstream.

Note You need to log in before you can comment on or make changes to this bug.