This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1288430 - /etc/tmpfiles.d/radiusd.conf shipped when /etc/tmpfiles.d is reserved for the local administrator
/etc/tmpfiles.d/radiusd.conf shipped when /etc/tmpfiles.d is reserved for the...
Status: CLOSED DUPLICATE of bug 1180979
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeradius (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Nikolai Kondrashov
Marek Marusic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 02:58 EST by Jan Pazdziora
Modified: 2016-04-18 11:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 11:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-12-04 02:58:31 EST
Description of problem:

freeradius ships /etc/tmpfiles.d/radius.conf.

Man page tmpfiles.d(5) says:

       Files in /etc/tmpfiles.d override files with the same name in
       /usr/lib/tmpfiles.d and /run/tmpfiles.d. Files in /run/tmpfiles.d
       override files with the same name in /usr/lib/tmpfiles.d. Packages
       should install their configuration files in /usr/lib/tmpfiles.d. Files
       in /etc/tmpfiles.d are reserved for the local administrator, who may
       use this logic to override the configuration files installed by vendor
       packages.

Version-Release number of selected component (if applicable):

freeradius-3.0.4-6.el7.x86_64

How reproducible:

Deterministic

Steps to Reproduce:
1. yum install -y freeradius
2. rpm -qf /etc/tmpfiles.d/radius.conf

Actual results:

freeradius-3.0.4-6.el7.x86_64

Expected results:

error: file /etc/tmpfiles.d/radius.conf: No such file or directory

Additional info:

Shipping package content for /etc/tmpfiles.d complicates containerization when it's important to distinguish software and configuration/data, and when rpm upgrade mechanism for config files is not available because no rpm upgrades happen there.
Comment 3 Nikolai Kondrashov 2016-04-18 11:59:56 EDT
Thanks for the report, Jan!
Thanks, Patrik, yes this is a duplicate of bug 1180979.

*** This bug has been marked as a duplicate of bug 1180979 ***

Note You need to log in before you can comment on or make changes to this bug.