Bug 1288434 - Mp3 Player use, degradation problem in spice
Mp3 Player use, degradation problem in spice
Status: CLOSED DUPLICATE of bug 1288437
Product: ovirt-guest-tools
Classification: oVirt
Component: QXL-Spice-Drivers (Show other bugs)
3.5-7
Unspecified Windows
low Severity medium (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 03:17 EST by Mr.M.
Modified: 2017-07-05 05:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-05 05:52:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Mr.M. 2015-12-04 03:17:59 EST
Description of problem:

Sorry, I used Google translation services.

In the case of Spice system, 
If you run MELON Music Player program...
Computer performance will be lowered to the level of a guest os is not available.
But, there is no problem in the protocol rdp.(ex. mstsc)
The Spice protocol only happens.(ex. remoteviewer)
Melon player is one of the most music playback program that is used in South Korea.


gdi32!NtGdiAlphaBlend+15


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install the Windows Guest OS. (Ex. Windows 7)
2. Install the Melon player.
   http://www.melon.com/customer/serviceintro/index.htm
   
   Attached Melon4Setup.7z setup file. (used 7 zip program)

3. Lanuch the Melon player.


Actual results:
   CPU resource used 40~50%


Expected results:


Additional info:

==========================
Report for Melon.DMP
==========================
Type of Analysis Performed
  Hang Analysis
Machine Name
  
Operating System
  Windows 7Service Pack 1
Number Of Processors
  
Process ID
  3056
Process Image
  C:\Program Files (x86)\MelOn Player4\Melon.exe
System Up-Time
  00:19:08
Process Up-Time
  00:00:22
Processor Type
  X64
Process Bitness
  32-Bit

Top 5 Threads by CPU time
Note - Times include both user mode and kernel mode for each thread
Thread ID: 0
    Total CPU Time: 00:00:19.562
    Entry Point for Thread: Melon!png_build_grayscale_palette+12eda2
Thread ID: 11
    Total CPU Time: 00:00:00.030
    Entry Point for Thread: mshtml!CExecFT::StaticThreadProc
Thread ID: 14
    Total CPU Time: 00:00:00.015
    Entry Point for Thread: mshtml!CExecFT::StaticThreadProc
Thread ID: 5
    Total CPU Time: 00:00:00.015
    Entry Point for Thread: rasman!RasmanServiceMonitorThread
Thread ID: 4
    Total CPU Time: 00:00:00.000
    Entry Point for Thread: ntdll_76f40000!TppWorkerThread




=====================================
Thread 0 - System ID 2864
=====================================
Entry point
  Melon!png_build_grayscale_palette+12eda2
Create time
  2015-09-18 ���� 10:00:34
Time spent in user mode
  0 Days 00:00:01.281
Time spent in kernel mode
  0 Days 00:00:18.281


This thread is not fully resolved and may or may not be a problem. Further analysis of these threads may be required.

Function
gdi32!NtGdiAlphaBlend+15
msimg32!AlphaBlend+b1
Melon!png_build_grayscale_palette+d411f
Melon!png_build_grayscale_palette+d42e9
Melon!png_build_grayscale_palette+c2bec
Melon!png_build_grayscale_palette+c3471
Melon!png_build_grayscale_palette+c36f3
Melon!png_build_grayscale_palette+12b653
mfc90u!CWnd::OnWndMsg+410
mfc90u!CWnd::WindowProc+24
mfc90u!AfxCallWndProc+a3
mfc90u!AfxWndProc+37
mfc90u!AfxWndProcBase+56
user32!InternalCallWinProc+23
user32!UserCallWinProcCheckWow+d8
user32!DispatchClientMessage+e0
user32!__fnDWORD+2b
ntdll_76f40000!KiUserCallbackDispatcher+2e
uxtheme!ThemeSetWindowRgn+112
user32!SetWindowRgn+54
Melon+fd44
Melon!png_build_grayscale_palette+cccc6
mfc90u!CWnd::OnWndMsg+443
mfc90u!CWnd::WindowProc+24
mfc90u!AfxCallWndProc+a3
mfc90u!AfxWndProc+37
mfc90u!AfxWndProcBase+56
user32!InternalCallWinProc+23
user32!UserCallWinProcCheckWow+109
user32!RealDefWindowProcWorker+622
user32!RealDefWindowProcW+4a
uxtheme!_ThemeDefWindowProc+197
uxtheme!ThemeDefWindowProcW+18
user32!DefWindowProcW+68
user32!DefWindowProcWorker+47
user32!DefDlgProcWorker+802
user32!DefDlgProcW+29
user32!InternalCallWinProc+23
user32!UserCallWinProcCheckWow+109
user32!CallWindowProcAorW+ab
user32!CallWindowProcW+1b
mfc90u!CWnd::DefWindowProcW+44
mfc90u!CWnd::Default+30
Melon+dc15
mfc90u!CWnd::OnWndMsg+407
mfc90u!CWnd::WindowProc+24
mfc90u!AfxCallWndProc+a3
mfc90u!AfxWndProc+37
mfc90u!AfxWndProcBase+56
user32!InternalCallWinProc+23
user32!UserCallWinProcCheckWow+d8
user32!DispatchClientMessage+e0
user32!__fnINLPWINDOWPOS+2c
ntdll_76f40000!KiUserCallbackDispatcher+2e
mfc90u!CWnd::RunModalLoop+128
user32!PeekMessageW+108
mfc90u!CDialog::DoModal+12a
Melon!png_build_grayscale_palette+bfb49
Melon+1945
Melon+4204
Melon+14a16
Melon!png_build_grayscale_palette+cb83e
mfc90u!CRuntimeClass::IsDerivedFrom+21
mfc90u!AfxDynamicDownCast+16
mfc90u!AfxDlgProc+31
user32!InternalCallWinProc+23
user32!UserCallDlgProcCheckWow+d7
user32!DefDlgProcWorker+b7
user32!DefDlgProcW+29
user32!InternalCallWinProc+23
user32!UserCallWinProcCheckWow+109
user32!CallWindowProcAorW+ab
user32!CallWindowProcW+1b
mfc90u!CWnd::DefWindowProcW+44
mfc90u!CWnd::Default+30
Melon!png_build_grayscale_palette+cbfc1
Melon!png_build_grayscale_palette+cc73c
mfc90u!CWnd::OnWndMsg+287
mfc90u!CWnd::WindowProc+24
mfc90u!AfxCallWndProc+a3
mfc90u!AfxWndProc+37
mfc90u!AfxWndProcBase+56
user32!InternalCallWinProc+23
user32!UserCallWinProcCheckWow+109
user32!SendMessageWorker+581
user32!InternalCreateDialog+b9f
user32!CreateDialogIndirectParamAorW+33
user32!CreateDialogIndirectParamW+1b
mfc90u!CWnd::CreateDlgIndirect+111
Melon!png_build_grayscale_palette+cbc63
Melon+22976
mfc90u!AfxWinMain+49
Melon!png_build_grayscale_palette+12ec33
kernel32!BaseThreadInitThunk+e
ntdll_76f40000!__RtlUserThreadStart+70
ntdll_76f40000!_RtlUserThreadStart+1b
Comment 1 Martin Tessun 2017-07-05 05:49:55 EDT
As the Melon page is obviously in Korean, can someone clarify a bit on what Melon is doing?

Afaik it is an audio player and does not have any "video" components in it, correct.

If this is correct, then I would assume that there is a bug somewhere in the audio tranmission/playback in SPICE somewhere.

David? Any ideas?
Comment 2 Martin Tessun 2017-07-05 05:52:49 EDT

*** This bug has been marked as a duplicate of bug 1288437 ***

Note You need to log in before you can comment on or make changes to this bug.