Bug 1288505 - ceres-solver must use current Eigen version
ceres-solver must use current Eigen version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ceres-solver (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Taylor Braun-Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 07:41 EST by Hannes Ovrén
Modified: 2016-03-27 21:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: ceres-solver-1.11.0-2.fc23 ceres-solver-1.10.0-6.fc22 ceres-solver-1.11.0-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-27 16:48:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hannes Ovrén 2015-12-04 07:41:12 EST
Description of problem:
Ceres apparently requires that it is used only together with the version of Eigen it was compiled with.
Current ceres-solver (1.11.0) is compiled against Eigen 3.2.5.
The current version of Eigen in Fedora is 3.2.7.
Thus compiling a ceres project in Fedora currently fails with a CMake error:

CMake Error at /usr/share/Ceres/CeresConfig.cmake:88 (message):
  Failed to find Ceres - Found Eigen dependency, but the version of Eigen
  found (3.2.7) does not exactly match the version of Eigen Ceres was
  compiled with (3.2.5).  This can cause subtle bugs by triggering violations
  of the One Definition Rule.  See the Wikipedia article
  http://en.wikipedia.org/wiki/One_Definition_Rule for more details


Version-Release number of selected component (if applicable):
1.11.0

How reproducible:
Always

Steps to Reproduce:
1. Try to build any project that use Ceres
Comment 1 Fedora Update System 2015-12-05 18:10:17 EST
ceres-solver-1.11.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7ce1be920b
Comment 2 Fedora Update System 2015-12-06 12:20:19 EST
ceres-solver-1.11.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update ceres-solver'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7ce1be920b
Comment 3 Fedora Update System 2015-12-29 17:25:37 EST
ceres-solver-1.11.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 Hannes Ovrén 2016-03-01 05:35:00 EST
eigen3-devel was updated from 3.2.7 to 3.2.8 recently (got the update today),
and since then the same issue as before is present with package ceres-solver-devel.
Comment 5 Rich Mattes 2016-03-01 12:28:08 EST
Oh no, I didn't notice the eigen3 update in my email. I'm building ceres-solver updates now.

Sandro, can you give me a heads up next time you build an eigen3 update, or rebuild ceres-solver at the same time?
Comment 6 Sandro Mani 2016-03-01 12:30:08 EST
Terribly sorry, I didn't realise that this was necessary for minor version updates also. Will do it in the future.
Comment 7 Rich Mattes 2016-03-01 12:39:06 EST
Yeah this package is kind of a special case.  It grabs the full version of eigen that it was built against and embeds it in the cmake config.  I've granted you commit access to ceres-solver so you can rebuild it when you update eigen3.
Comment 8 Sandro Mani 2016-03-01 12:40:23 EST
Ok, thanks.
Comment 9 Fedora Update System 2016-03-02 12:25:09 EST
ceres-solver-1.11.0-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6bc25bf197
Comment 10 Fedora Update System 2016-03-02 12:25:10 EST
ceres-solver-1.10.0-6.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd74529f16
Comment 11 Fedora Update System 2016-03-03 16:55:21 EST
ceres-solver-1.10.0-6.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd74529f16
Comment 12 Fedora Update System 2016-03-03 16:58:33 EST
ceres-solver-1.11.0-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6bc25bf197
Comment 13 Fedora Update System 2016-03-27 16:48:23 EDT
ceres-solver-1.10.0-6.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-03-27 21:19:24 EDT
ceres-solver-1.11.0-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.