Bug 1288510 - Python-boto fails to build in F23 and rawhide
Python-boto fails to build in F23 and rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 08:07 EST by Ryan Brown
Modified: 2015-12-04 16:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 16:31:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for rawhide specfile (5.25 KB, application/mbox)
2015-12-04 08:07 EST, Ryan Brown
no flags Details
Patch for f23 specfile (5.26 KB, patch)
2015-12-04 08:08 EST, Ryan Brown
no flags Details | Diff

  None (edit)
Description Ryan Brown 2015-12-04 08:07:09 EST
Created attachment 1102264 [details]
Patch for rawhide specfile

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download python-boto package
2. Check out `master` or `f23`
3. Attempt a mockbuild

Actual results:
Build fails with a failure of a Glacier unittest (due to unittest.mock equality test against MagicMock).

Expected results:

Additional info:
I've proposed a fix upstream https://github.com/boto/boto/pull/3412 and attached patches for both branches to fix the build in Fedora.
Comment 1 Ryan Brown 2015-12-04 08:08 EST
Created attachment 1102265 [details]
Patch for f23 specfile
Comment 2 Orion Poplawski 2015-12-04 16:31:14 EST
Thanks.  Applied minus the conditional (generally try not to conditionally apply patches).

Note You need to log in before you can comment on or make changes to this bug.