This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 128854 - libcurl.so.2 is not provide by curl, when it need neede by php
libcurl.so.2 is not provide by curl, when it need neede by php
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
: 128933 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-30 12:13 EDT by Knut J BJuland
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.3.8-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-08 06:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2004-07-30 12:13:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
curl is missing libcurl.so.2 which is need by php in rawhide. Please
add lincurl.so.2 by symlink it with libcurl.so

Version-Release number of selected component (if applicable):
7.12.0-2

How reproducible:
Always

Steps to Reproduce:
1. install curl whne php is installed
2.
3.
    

Actual Results:  unable to install curl due to missing libcurl.so.2

Expected Results:  curl should be installed without problem

Additional info:
Comment 1 Daniel Stenberg 2004-08-04 09:04:23 EDT
curl 7.12 and later creates libcurl.so.3 due to ABI changes
Comment 2 Leonard den Ottolander 2004-08-07 09:21:18 EDT
In that case php should be updated. Changing component.
Comment 3 Leonard den Ottolander 2004-08-07 09:38:20 EDT
*** Bug 128933 has been marked as a duplicate of this bug. ***
Comment 4 Leonard den Ottolander 2004-08-07 09:42:41 EDT
The version change of libcurl requires an update of php.
EASYFIX.

(Robert, I was just adding you when this midair collision occured.)
Comment 5 Joe Orton 2004-08-08 06:17:59 EDT
Sorry for the delay, I've been away on holiday.  php-4.3.8-4 was built
yesterday against the new curl.
Comment 6 Leonard den Ottolander 2004-08-08 10:20:16 EDT
I figured something like that. I was just about to ask on IRC :-) .
Hope you had a good holiday!

Note You need to log in before you can comment on or make changes to this bug.