Bug 1288557 - Automate Method quota doesn't correctly handle sub 1GB storage requests [NEEDINFO]
Automate Method quota doesn't correctly handle sub 1GB storage requests
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 09:54 EST by Pete Savage
Modified: 2015-12-22 12:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 12:12:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tfitzger: needinfo? (psavage)


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-12-04 09:54:02 EST
Description of problem: Automate Method doesn't correctly handle sub 1GB storage requests


Version-Release number of selected component (if applicable): 5.5.0.13


How reproducible: 100%


Steps to Reproduce:
1. Apply a limit of 1GB in the / Service / Provisioning / StateMachines / ServiceProvisionRequestQuotaVerification / instance
2. Run a provisioning with 400Mb storage * 3
3.

Actual results: All three are allowed


Expected results: The last one should be stopped


Additional info:
This is happening because of the conversion from Bytes to GB, In the conversion an integer is obtained, which is rounded. In the logs we see {:allocated=>1, :requested=>0, :limit=>1

Requested = 0 because it's rounded down in the conversion to GB. This effectively means that the user can use up more storage than they are allowed.
Comment 2 Tina Fitzgerald 2015-12-17 15:04:09 EST
Hi Pete,

This issue is resolved in the new consolidated quota.

Is it okay to close this ticket since this code is deprecated?

Thanks,
Tina
Comment 3 Tina Fitzgerald 2015-12-22 12:12:03 EST
This issue is resolved in the new consolidated quota.

Note You need to log in before you can comment on or make changes to this bug.