Bug 1288630 - Cannot compile any sketch
Cannot compile any sketch
Status: CLOSED DUPLICATE of bug 1259646
Product: Fedora
Classification: Fedora
Component: arduino (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dennis Chen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 14:55 EST by Alberto Ruiz
Modified: 2015-12-04 16:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 16:10:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alberto Ruiz 2015-12-04 14:55:58 EST
Description of problem:
Arduino does not compile any sketches

Version-Release number of selected component (if applicable):
1.0.6

How reproducible:
Always

Steps to Reproduce:
1. open Arduino
2. load a sample sketch like the Blink one
3. try to compile/verify any sketch

Actual results:

Arduino: 1.0.6 (Linux), Board: "Arduino Uno"
avr-gcc -Os -Wl,--gc-sections -mmcu=atmega328p -o /tmp/build4247694257330758195.tmp/Blink.cpp.elf /tmp/build4247694257330758195.tmp/Blink.cpp.o /tmp/build4247694257330758195.tmp/core.a -L/tmp/build4247694257330758195.tmp -lm 

/usr/lib/gcc/avr/5.1.0/../../../../avr/bin/ld: cannot find dev/atmega328p/crt1.o: No such file or directory
/usr/lib/gcc/avr/5.1.0/../../../../avr/bin/ld: cannot find dev/atmega328p/libdev.a: No such file or directory
collect2: error: ld returned 1 exit status
Comment 1 Dennis Chen 2015-12-04 16:10:17 EST

*** This bug has been marked as a duplicate of bug 1259646 ***

Note You need to log in before you can comment on or make changes to this bug.