Bug 128884 - While connecting to session manager: While connecting to Session Manager: Could not open network socket - with gnome and kde
While connecting to session manager: While connecting to Session Manager: Cou...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-30 17:03 EDT by John H.
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 01:45:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John H. 2004-07-30 17:03:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040618 Galeon/1.3.15.99

Description of problem:
While connecting to session manager: Could not open network socket.

I get this error running gnome or kde apps in X.  If I restart X, it
goes away for a while, then it returns.  When it returns, programs
start far slower, and some do not start at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Restart X
2.Wait or run gnome/kde apps a few times.

    

Additional info:
Comment 1 Mike A. Harris 2004-12-04 01:45:42 EST
My assumption is that your hostname is changing via DHCP while
your X server is running.  That will prevent applications from
starting, and is a hard limitation in the way X authorization
works.  If you use DHCP to obtain IP address and your X server
is using your IP address for authentication purposes, you'll have
to restart the X server in order to run X apps.

Since no other reports of this nature have been reported to us
in bugzilla, and I'm unable to reproduce this in Fedora Core 2
or 3, my assumption is that this is the DHCP related limitation
of X mentioned above, or some other local configuration or
installation problem.

If the problem persists, please upgrade to Fedora Core 3 to
see if that changes anything.  You may also seek troubleshooting
and configuration assistance on the Red Hat public mailing
lists, which may help narrow down the source of your problem.
If the problem does persist, once you've narrowed it down to
a specific cause, should that turn out to be an X bug, please
file a new bug report detailing the problem.

Thanks.


Setting status to "WORKSFORME", unable to reproduce.

Note You need to log in before you can comment on or make changes to this bug.