Bug 1288969 - Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached
Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout wa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm-ostree (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 01:46 EST by Chris Murphy
Modified: 2015-12-08 14:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 14:52:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace rpm-ostree status (55.90 KB, text/plain)
2015-12-07 01:46 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2015-12-07 01:46:09 EST
Created attachment 1103033 [details]
strace rpm-ostree status

Description of problem:

After upgrading from 23.22 to 23.27, the command 'rpm-ostree status' fails with an error message.

Version-Release number of selected component (if applicable):
Fedora-Cloud-Atomic-23-20151201.x86_64.qcow2
rpm-ostree-2015.10-1.fc23.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Create a new qcow2 with Fedora Atomic Host as backing file: 
# qemu-img create -f qcow2 -b Fedora-Cloud-Atomic-23-20151201.x86_64.qcow2 
FCA23-20151201-20151206.qcow2
2. Create a simple init.iso per project atomic quickstart guide, and attach as cdrom.
3. Boot
4. $ sudo rpm-ostree upgrade
Updating from: fedora-atomic:fedora-atomic/f23/x86_64/docker-host

40 metadata, 106 content objects fetched; 99046 KiB transferred in 16 seconds
Copying /etc changes: 22 modified, 0 removed, 43 added
Transaction complete; bootconfig swap: yes deployment count change: 1
Changed:
  dbus 1:1.10.4-1.fc23 -> 1:1.10.6-1.fc23
  dbus-libs 1:1.10.4-1.fc23 -> 1:1.10.6-1.fc23
  glibc 2.22-5.fc23 -> 2.22-6.fc23
  glibc-common 2.22-5.fc23 -> 2.22-6.fc23
  grep 2.22-2.fc23 -> 2.22-3.fc23
  krb5-libs 1.13.2-13.fc23 -> 1.14-2.fc23
  libxml2 2.9.3-1.fc23 -> 2.9.3-2.fc23
  nettle 3.1.1-4.fc23 -> 3.1.1-5.fc23
  openssl 1:1.0.2d-3.fc23 -> 1:1.0.2e-1.fc23
  openssl-libs 1:1.0.2d-3.fc23 -> 1:1.0.2e-1.fc23
  pcre 8.38-2.fc23 -> 8.38-3.fc23
  python3-libxml2 2.9.3-1.fc23 -> 2.9.3-2.fc23
  rpcbind 0.2.3-0.4.fc23 -> 0.2.3-5.fc23
  rpm-ostree 2015.9-2.fc23 -> 2015.10-1.fc23
Upgrade prepared for next boot; run "systemctl reboot" to start a reboot
[fedora@atomic01 ~]$ rpm-ostree status
  TIMESTAMP (UTC)         VERSION   ID             OSNAME            REFSPEC                                                
  2015-12-06 18:54:26     23.27     9142ba709a     fedora-atomic     fedora-atomic:fedora-atomic/f23/x86_64/docker-host     
* 2015-11-30 21:02:28     23.22     253ec42e3c     fedora-atomic     fedora-atomic:fedora-atomic/f23/x86_64/docker-host     
[fedora@atomic01 ~]$ sudo reboot

[fedora@atomic01 ~]$ rpm-ostree status
error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached



Actual results:

error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached

Doesn't matter whether I'm user fedora, or use sudo, or switch to root using sudo -i and then running the command. All fail.

Expected results:

I should get a proper status output.


Additional info:

strace attached
Comment 1 Chris Murphy 2015-12-07 01:49:48 EST
OK if I boot the 23.27 option (default) in the GRUB menu, I hit this bug. If I reboot and choose 23.22 option in the GRUB menu, the command works.
Comment 2 Colin Walters 2015-12-08 10:45:04 EST
This is because rpm-ostree needs the newer ostree, but https://bodhi.fedoraproject.org/updates/FEDORA-2015-5b7f64f027 didn't go stable at the same time.

It worked when rebasing to the updates-testing ref because they come together.
Comment 3 Fedora Update System 2015-12-08 10:46:07 EST
ostree-2015.11-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5b7f64f027
Comment 4 Fedora Update System 2015-12-08 14:52:07 EST
ostree-2015.11-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.