This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1288970 - An error occurred when input an unreachable Engine FQDN address to register RHEVM
An error occurred when input an unreachable Engine FQDN address to register R...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Douglas Schilling Landgraf
cshao
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 01:50 EST by yileye
Modified: 2016-01-28 15:31 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 13:29:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (40.05 KB, image/png)
2015-12-07 01:50 EST, yileye
no flags Details
var log (5.75 MB, application/x-bzip)
2015-12-07 01:52 EST, yileye
no flags Details

  None (edit)
Description yileye 2015-12-07 01:50:54 EST
Created attachment 1103036 [details]
Screenshot

Description of problem:
when input an invalid Engine FQDN  address to register rhevm, the ovirt-node.log and reister.log file show Traceback info.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151201.2
ovirt-node-plugin-vdsm-0.6.1-4.el7ev.noarch

How reproducible:
100%
QA Whiteboard: TUI

Steps to Reproduce:
 1. TUI clean install rhev-hypervisor7-7.2-20151201.2 successful with no error.
 2. IN ‘Network‘ Page,Enable NIC via DHCP and enable SSH.
 3. In ‘RHEV-M’ page ,Input an invalid Engine FQDN  address.
 4. Click ‘Save’.

Test result:
After step4, output some message:

Transaction: Configuring RHEV-M                                                             │                                                                                                                                                                               Checking pre-conditions ...                                                                 │
│(1/1) Registering oVirt Node...                                                             │
│                                                                                            │
│An error occurred while applying the changes:                                               │
│Cannot register the node into 10.66.10.238!                                                 │
│Connection refused to 10.66.10.238                                                          │
│Full log: /var/log/vdsm/register.log


Additional info:
#ovirt-node.log
<snip>
2015-12-02 02:27:07,974       INFO Current page is 'RHEV-M'
2015-12-02 02:27:11,274    WARNING No widget for path action.register
2015-12-02 02:27:11,275    WARNING No widget for path action.register
2015-12-02 02:27:11,294       INFO Running <function <lambda> at 0x8594848>
2015-12-02 02:27:15,021       INFO Captured nothing
2015-12-02 02:27:15,021       INFO An exception during the transaction: Cannot register the node into 10.66.10.238!
Connection refused to 10.66.10.238
Full log: /var/log/vdsm/register.log
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 956, in __run_transaction
    self.plugin.dry_or(lambda: tx_element.commit())
  File "/usr/lib/python2.7/site-packages/ovirt/node/plugins.py", line 188, in dry_or
    return func()
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 956, in <lambda>
    self.plugin.dry_or(lambda: tx_element.commit())
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/vdsm/engine_page.py", line 392, in commit
    raise Exception(msg)
Exception: Cannot register the node into 10.66.10.238!
Connection refused to 10.66.10.238
Full log: /var/log/vdsm/register.log
2015-12-02 02:27:16,798       INFO Changes were merged successfully
</snip>

#/vdsm/register.log
<snip>
2/02/2015 01:54:32 AM Received the following attributes:
12/02/2015 01:54:32 AM Engine FQDN: 10.66.10.238
12/02/2015 01:54:32 AM Engine URL: https://10.66.10.238:443
12/02/2015 01:54:32 AM Engine https port: 443
12/02/2015 01:54:32 AM Check FQDN: False
12/02/2015 01:54:32 AM Fingerprint: None
12/02/2015 01:54:32 AM Node address: None
12/02/2015 01:54:32 AM Node name: localhost
12/02/2015 01:54:32 AM SSH User: root
12/02/2015 01:54:32 AM SSH Port: 22
12/02/2015 01:54:32 AM VDSM Port: 54321
12/02/2015 01:54:32 AM VDSM UUID: None
12/02/2015 01:54:32 AM Engine CA: /etc/pki/ovirt-engine/ca.pem
12/02/2015 01:54:32 AM Starting registration...
12/02/2015 01:54:32 AM Get version via: https://10.66.10.238/ovirt-engine/services/host-register?version=1&command=get-version
12/02/2015 01:54:32 AM Cannot connect to engine. 10.66.10.238 matches the FQDN of Engine?
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/tool/register.py", line 476, in main
    reg.handshake()
  File "/usr/lib/python2.7/site-packages/vdsm/tool/register.py", line 138, in handshake
    res = requests.get(__GET_VERSION, verify=False)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 68, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 50, in request
    response = session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 464, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 576, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 415, in send
    raise ConnectionError(err, request=request)
ConnectionError: ('Connection aborted.', error(111, 'Connection refused'))
</snip>
Comment 1 yileye 2015-12-07 01:52 EST
Created attachment 1103037 [details]
var log
Comment 2 Ying Cui 2015-12-07 05:21:43 EST
Leye, invalid Engine FQDN address OR unreachable Engine FQDN address?
Comment 3 yileye 2015-12-07 05:29:05 EST
It is a unreachable Engine FQDN address.
Comment 4 Fabian Deutsch 2015-12-07 05:55:40 EST
This bug was also filed before, it was closed.

As this was encountered again, and spawned a bug, we'll keep it with low priority.
Comment 5 Ying Cui 2015-12-07 07:34:16 EST
(In reply to Fabian Deutsch from comment #4)
> This bug was also filed before, it was closed.

you mean this [VERIFIED]Bug 1272216 - input a host/ip which is not rhev-m: list index out of range

> 
> As this was encountered again, and spawned a bug, we'll keep it with low
> priority.

From QE point of view, we consider to fix this bug because UI display _ERROR_ not warning messages when registering to unreachable engine, and move to new vdsm register?
Comment 11 Douglas Schilling Landgraf 2016-01-28 13:29:21 EST
(In reply to Ying Cui from comment #5)
> (In reply to Fabian Deutsch from comment #4)
> > This bug was also filed before, it was closed.
> 
> you mean this [VERIFIED]Bug 1272216 - input a host/ip which is not rhev-m:
> list index out of range
> 
> > 
> > As this was encountered again, and spawned a bug, we'll keep it with low
> > priority.
> 
> From QE point of view, we consider to fix this bug because UI display
> _ERROR_ not warning messages when registering to unreachable engine, and
> move to new vdsm register?

Why warning if there is no communication back ('connection refused') from the machine which suppose to be the Engine? The message is clear from python exception, 'connection refused', which might be user input error (engine address) or firewall blocking. For now, I am closing the bug as not a bug.
Comment 12 Fabian Deutsch 2016-01-28 15:08:33 EST
Douglas, does the TUI show a traceback and is quit?

Or is a dialog shown to inform the user that it could not connect?

It should be showing a dialog, and not cause a traceback.
Comment 13 Douglas Schilling Landgraf 2016-01-28 15:16:14 EST
(In reply to Fabian Deutsch from comment #12)
> Douglas, does the TUI show a traceback and is quit?
> 
> Or is a dialog shown to inform the user that it could not connect?
> 
> It should be showing a dialog, and not cause a traceback.

Only a message, the reporter also added the traceback from the logs, users don't see it at all.

Transaction: Configuring RHEV-M                                                             │                                                                                                                                                                               Checking pre-conditions ...                                                                 │
│(1/1) Registering oVirt Node...                                                             │
│                                                                                            │
│An error occurred while applying the changes:                                               │
│Cannot register the node into 10.66.10.238!                                                 │
│Connection refused to 10.66.10.238                                                          │
│Full log: /var/log/vdsm/register.log
Comment 14 Fabian Deutsch 2016-01-28 15:31:26 EST
That looks like a perfect message.

Note You need to log in before you can comment on or make changes to this bug.