Bug 1289008 - Run command "oo-admin-usage -h/--help" show undefined method
Run command "oo-admin-usage -h/--help" show undefined method
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rory Thrasher
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 03:41 EST by Liang Xia
Modified: 2017-05-31 14:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liang Xia 2015-12-07 03:41:08 EST
Description of problem:
Run command "oo-admin-usage -h" or "oo-admin-usage --help",
got undefined method error:
# oo-admin-usage -h
/usr/sbin/oo-admin-usage:33:in `show_usage': undefined method `<<' for nil:NilClass (NoMethodError)
    from /usr/sbin/oo-admin-usage:162:in `<main>'

Version-Release number of selected component (if applicable):
devenv_5730

How reproducible:
Always

Steps to Reproduce:
1.SSH into server, and run command "oo-admin-usage -h"

Actual results:
# oo-admin-usage -h
/usr/sbin/oo-admin-usage:33:in `show_usage': undefined method `<<' for nil:NilClass (NoMethodError)
    from /usr/sbin/oo-admin-usage:162:in `<main>'

Expected results:
Help info printed out.

Additional info:
https://github.com/openshift/origin-server/commit/8617728bdc3b22f5058bf32edf28d198c910817e#diff-0344ca4562b0e165cfed0d219c5a5eabL7
Comment 1 openshift-github-bot 2016-01-07 19:14:13 EST
Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/a82a40616cb0fdbde254f9f9b2075ee02a32cccf
oo-admin-usage: fix help message

Bug 1289008
BZ https://bugzilla.redhat.com/show_bug.cgi?id=1289008

The help options for oo-admin-usage (-h and --help) were giving error messages
instead of displaying the usage options.  The -h and --help flags will now
correctly display the usage options.

https://github.com/openshift/origin-server/commit/6519124b5f8cb46a599bbf0600466e4da972b773
Merge pull request #6344 from thrasher-redhat/bug1289008

Merged by openshift-bot
Comment 3 Liang Xia 2016-01-07 22:06:21 EST
sorry, please ignore #comment 2. It means to be in another bug.
Comment 4 Liang Xia 2016-01-07 22:19:39 EST
Verified it's fixed on devenv_5749

# oo-admin-usage -h
== Synopsis

oo-admin-usage: List the usage data for a user or aggregated usage data of all users for the given timeframe.
Note: The usage cost displayed is based on the usage duration and the usage rate.
It does not take into account any unbilled usage by the billing provider.

== Usage

oo-admin-usage OPTIONS

Options:
-l|--login
    The user login whose usage data is to be displayed
-a|--app
    The application name to filter the usage data
-g|--gear
    The gear id to filter the usage data
-p|--plan
    Current user plan to filter the usage data
-s|--start
    The start date (yyyy-mm-dd) to filter the usage data (defaults to start of current month in UTC)
-e|--end
    The end date (yyyy-mm-dd) to filter the usage data (defaults to the current time in UTC)
-h|--help
    Show Usage info
Comment 5 Rory Thrasher 2016-01-08 10:48:33 EST
Looks like Liang has already verified this, but its still good to go through the process.

QA, can you please verify that the help messages for oo-admin-usage are no longer providing errors?

1. oo-admin-usage -h

2. oo-admin-usage --help
Comment 6 Liang Xia 2016-01-10 21:14:34 EST
Verified it's fixed on devenv_5751

# oo-admin-usage -h
== Synopsis

oo-admin-usage: List the usage data for a user or aggregated usage data of all users for the given timeframe.
Note: The usage cost displayed is based on the usage duration and the usage rate.
It does not take into account any unbilled usage by the billing provider.

== Usage

oo-admin-usage OPTIONS

Options:
-l|--login
    The user login whose usage data is to be displayed
-a|--app
    The application name to filter the usage data
-g|--gear
    The gear id to filter the usage data
-p|--plan
    Current user plan to filter the usage data
-s|--start
    The start date (yyyy-mm-dd) to filter the usage data (defaults to start of current month in UTC)
-e|--end
    The end date (yyyy-mm-dd) to filter the usage data (defaults to the current time in UTC)
-h|--help
    Show Usage info



# oo-admin-usage --help
== Synopsis

oo-admin-usage: List the usage data for a user or aggregated usage data of all users for the given timeframe.
Note: The usage cost displayed is based on the usage duration and the usage rate.
It does not take into account any unbilled usage by the billing provider.

== Usage

oo-admin-usage OPTIONS

Options:
-l|--login
    The user login whose usage data is to be displayed
-a|--app
    The application name to filter the usage data
-g|--gear
    The gear id to filter the usage data
-p|--plan
    Current user plan to filter the usage data
-s|--start
    The start date (yyyy-mm-dd) to filter the usage data (defaults to start of current month in UTC)
-e|--end
    The end date (yyyy-mm-dd) to filter the usage data (defaults to the current time in UTC)
-h|--help
    Show Usage info
Comment 8 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.