Bug 1289037 - [WebAdmin] - Error message appears in the UI "Uncaught exception occurred. Please try reloading the page." while pressing the 'Import' button in the VM Import sub tab, under Storage main tab
[WebAdmin] - Error message appears in the UI "Uncaught exception occurred. Pl...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1.1
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Tal Nisan
Elad
:
: 1291703 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 05:05 EST by Michael Burman
Modified: 2016-02-18 06:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:09:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
amureini: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
server log and screen shots (573.71 KB, application/x-gzip)
2015-12-07 05:05 EST, Michael Burman
no flags Details
javaconsole (430.98 KB, application/x-gzip)
2015-12-09 05:15 EST, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50259 master MERGED webadmin: Handle ClassCastException in import VM/template popups Never
oVirt gerrit 50391 ovirt-engine-3.6 MERGED webadmin: Handle ClassCastException in import VM/template popups Never

  None (edit)
Description Michael Burman 2015-12-07 05:05:00 EST
Created attachment 1103104 [details]
server log and screen shots

Description of problem:
[WebAdmin] - Error message appears in the UI "Uncaught exception occurred. Please try reloading the page." while pressing the 'Import' button in the VM Import sub tab, under Storage main tab.

Every time pressing the 'Import' button on the latest 3.6.1.1 engine under [Storage] > VM Import > press 'Import' button, the next error message appears(colored in red) in the front UI:
"Uncaught exception occurred. Please try reloading the page."


server.log:

2015-12-07 09:50:42,034 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/ovirt-engine/webadmin]] (ajp-/127.0.0.1:8702-12) Exception while dispatching incoming RPC call: com.google.gwt.use
r.client.rpc.RpcTokenException: Invalid RPC token (Invalid XSRF token)

- The full exception attached in the log.

Version-Release number of selected component (if applicable):
3.6.1.1-0.1.el6

How reproducible:
100

Steps to Reproduce:
1. Export VM to export domain
2. Press 'Import' button to import this VM

Actual results:
"Uncaught exception occurred. Please try reloading the page."
Error message appears in the UI .
Every time i will press 'Import' this error message will be displayed one above the other. Until reloading the page.

Expected results:
Not sure, because if it's a part of the new UI feature, then it should be improved i think. And what and why is this 'Uncaught exception occurs in the first place when importing VM..?
Comment 1 Einav Cohen 2015-12-08 10:26:57 EST
please upload javascript console logs/stack-traces as well - I'm guessing there is an application-level exception (NPE, most likey) in the Import flow. 

(storage team: javascript stack-trace will be obfuscated, but can be easily "translated" to non-obfuscated javascript which should clarify the root cause of the problem - contact awels if you need assistance doing that).
Comment 2 Michael Burman 2015-12-09 05:15 EST
Created attachment 1103820 [details]
javaconsole
Comment 3 Michael Burman 2015-12-09 05:16:23 EST
I'm attaching the output of the javascript console logs/stack-traces when getting the exception.
"SEVERE: Uncaught exception: java.lang.ClassCastException"

-I hope it's good enough..if not, please contact me and i will share my setup details for debugging. Thanks.
Comment 4 Dan Kenigsberg 2015-12-16 10:27:01 EST
*** Bug 1291703 has been marked as a duplicate of this bug. ***
Comment 5 Sandro Bonazzola 2015-12-23 08:43:47 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 6 Elad 2016-01-10 09:25:23 EST
Clicking on 'Import' for importing a VM from an export domain, both from 'Virtual machines' tab -> import and 'Storage' tab -> export domain -> import doesn't give the mentioned error message.

Verified using rhevm-webadmin-portal-3.6.2-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.